WPS Office theme issue with KDE Neon

Hello KDE Team,
Firstly, let me give my heartfelt thanks to all the developers and the entire team for these amazing developments over the years.

Coming to my question,

Issue: I am facing a theme issue with WPS 2019 office suite in KDE Neon. The office suite works well, but I have a particular find when I try to filter things out in excel. The filter options color is greyed/whitened out. And I am not able to view options when I try to filter the excel column.

My KDE Neon settings:

Theme: Breeze Dark
KDE Neon Ver: 5.27
Kernel Ver: 6.5.0-21
DE Ver: 5.27.10
WPS Office suite: 2019

I have downloaded and set up the WPS office using the official deb package available from their website.

Steps tried to resolve:

  1. I have tried to remove and re-install the deb package
  2. I have tried to change the theme from Breeze Dark to Breeze
  3. I have tried changing the theme within the WPS (even though things are in Chinese and there is only 2 theme options)

Nothing works, I need the filter color to be visible as I work with a lot of excel sheets.
I am a long time Linux user coming back to Linux, this time for office use, and since there is no Microsoft suite support, the closest I could find was WPS Office.

Hope to get a resolution on this.

i just installed the snap package on kubuntu and filtering works as intended but there are reports of issues with the version downloaded from the website

plus the snap is telemetry free… so if you haven’t tried the snap, i would recommend it.

Such a great find @skyfishgoo thank you! :smile:

I uninstalled the default official .deb package and re-installed with snap.

And now, everything works great.
This resolves my issue. Now the theme is not broken, and filter options are visible.

Also, for people having issue with printing documents, you can add the below commands to allow wps-2019-snap access to printer and few other devices.

It is explained by the developer on snapcraft website, but here are the commands to be executed anyways.

  1. sudo snap connect wps-2019-snap:cups-control :cups-control
  2. sudo snap connect wps-2019-snap:pulseaudio :pulseaudio
  3. sudo snap connect wps-2019-snap:alsa :alsa
  4. sudo snap connect wps-2019-snap:removable-media :removable-media

Hope this helps!

1 Like

Seems like those extra 4 commands should be something handled by the snap package manager, should it not?

glad that work, and im actually pretty impressed with how fast the app comes up when called.

i also use typora in snap form and it’s very slow to start for some reason.

agreed… there needs to be a GUI front end to the snap permissions similar to flatseal so we can manage them at install time.

i like that snap installs with basically no permissions as the default but for some packages that require greater integration with the OS to be fully functional, we should have an easy way to make that happen if we choose.

Yep, there is a setting in the snap store (if installed), by going to Snap Store > Installed > Application Name > Permissions.

Here is the snap for the same.

TIL that in discover there is a button for configuring permissions of snap packages… thanks for pointing that out.

1 Like