Wrong fonts and icons missing after Manjaro KDE update to 5.27

It happened about two months ago with the first 5.27 Manjaro update. I’ve been busy with work and had GNOME as well so just switched to GNOME and in the meantime, I’ve tried different solutions I could find on forums. I think I’ve tried every trick I could find with no luck. I’ve tried different GPU drivers, both NVIDIA free and proprietary as well as using only the Intel i915 driver. I’ve removed kde cache directory. I’ve changed themes a few times and even downgraded libscreen to 5.26 but I still same issue. I’ve recovered a few icons but still, size of both icons and fonts is not right, especially in Settings and Konsole terminal. Currently, I’m at 5.27.6 hoping it’s a bug and been fixed.
Some screenshots

Apologies, but aside from the weird spacing in the ls output, I don’t see issues with neither icons nor fonts.

1 Like

You can see some text is not visible, and the output is not formatted correctly. I’ve also had other screenshots but was only allowed to post one. In this screenshot, you can see Dolphin icons and fonts are wrong as well. Looks like the fonts and icons are not found at all and some default is used or something.

I’m not familiar with Manjaro (though I heard many describe their packaging practices as inconsistent at best). I would try to reinstall all the “breeze” related packages you have installed.

It does look like a last resort to reinstall minimal KDE and see what happens. I’ve tried both Breeze, Breath and some other default themes but non of them is working. I have an open topic at the Manjaro forum and tried all the tricks for removing and rebuilding the cache but nothing helped.

Create a new user and see if the issue happens also there. If the new user works I think your issue is somewhere in your home folder. Next step then would be to check your ~/.config folder.
Also please link your manjaro post so we can see what they already suggested.

A new user hasn’t got this problem. See the screenshot below. I’ve already tried to remove all KDE-related cache config files for my existing user, hoping it’s going to do the trick, but I’ve had no luck so far. Maybe I’m missing something. Most recently, I’ve run

cd ~/.config && for j in plasma*; 
do mv -- "$j" "${j%}.bak"; done && rm ~/.config/Trolltech.conf 
cd ~ && kbuildsycoca5 --noincremental

The Manjaro post link is Wrong fonts and icons missing after Manjaro KDE update to 5.27 - #3 by mirek186 - KDE Plasma - Manjaro Linux Forum

My guess is that it is the gnome config files are causing issues not the kde ones (since running both gnome and kde on the same user often leads to issues). Or something that gnome touched.
Are you still using gnome or have you removed it?

I finally get it working again. Thanks for all the help. Unfortunately, I don’t know if all 3 are required or which one did the trick, as I’ve done all three before testing again. With Gnome and KDE i had deps issue manjaro-kde-settings package conflicting with manjaro-gnome-settings, somewhere in the forum, I’ve read it’s only used for init settings and I had to remove one. So I’ve removed KDE months ago. It does affect .xinitrc file, however, I had the same issues in Wayland so hard to say don’t know what Wayland is using to init and it’s been working fine for months and many updates in between, so I don’t think that’s the issue, today I’ve removed GNOME completely, installed the KDE settings package and also removed icon and font cache files.

~/.cache/icon-cache.kcache and ~/.cache/fontconfig/*

and I’ve got my desktop back. Hard to say if cache helped as I already did remove cache once before with no luck and again I happily run both GNOME and KDE for months before the issue started. I think something introduced with an update to GNOME or KDE a few weeks back broke things.