Can't disable G-Sync in Wayland

As the title says I can’t disable G-Sync in KDE Wayland on my monitor. Adaptive sync is set to never in KDE display configuration. I can’t enable ULMB2 unless G-Sync mode is off. Is there any way to disable it?

I’m on EndeavourOS (6.6.7 kernel) KDE Wayland using nvidia 545.29.06 driver.

Here’s a screenshot

Not sure if this is a bug so I’m asking here first before posting a bug report.