Can't get Krfb/KRDC to work on fresh Debian 12.1 install

So I recently installed Debian 12.1 (bookworm) on my desktop, and rebuilt my laptop with it as well. Trying to get Remote Desktop working using Krfb (on desktop) and KRDC (on laptop). When I try and connect (VNC protocol) from my laptop with KRDC to my desktop with Krfb, I get the password prompt on the laptop, enter it, get the “accept/deny” connection in Krfb on the desktop, Accept it, and then KRDC fails and nothing happens.

Here’s the output from the desktop

$ krfb
Initializing D-Bus connectivity with XDG Desktop Portal
DBus session created:  "/org/freedesktop/portal/desktop/request/1_833/krfb1857091082"
krfb.framebuffer.pipewire: Couldn't open pipewire remote for the screen-casting session

Laptop with KRDC says this, with the 2nd line only after it says “authentication failed” after I hit Accept on Krfb.

$ krdc 
KRDC: rfbInitClient failed

System info:
GPU is 7900XT, doesn’t say it here.

Operating System: Debian GNU/Linux 12
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8
Kernel Version: 6.1.0-12-amd64 (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 5800X3D 8-Core Processor
Memory: 94.2 GiB of RAM
Graphics Processor: AMD Radeon Graphics
Manufacturer: BIOSTAR Group
Product Name: X370GT7


no issue on my side with krdc to remote the devices (linux arm, windows os…)
wayland since 3 months, krfb && krdc user since ~ 2018.

for the moment avoid to share a device (krfb) with wayland but prefer x11
krfb have an option, enable unattended access.

more infos :

what is the status of

sudo systemctl status nftables

take care, for the vnc like the ssh… your firewall have to be configure, port have to be allow

So not at home for a bit so can’t check, but AFAIK it’s open, but my network is behind opnSense NAT router, so I have to SSH in to my home server, and port forward from there.

However, I got Remote Desktop using the RDP protocol for Plasma Wayland working OK with Remmina, with the same SSH port forward method, so I’ll be using this for now.

1 Like

I had the same issue with krfb and krdc on debian 12. For me, it helped to stop / disable apparmor and to open the firewall for vnc (using krfb/krdc with vnc).

1 Like


thanks for your feedback.
I remote with a wayland computer the sharing desktop computers running with x11 display manager, I ssh the sharing desktop computer, stop their firewall and remote the x11 sharing computer.
krfb & krdc to share and remote.