Difficulty with KDE Plasma Screen Sharing Feature

I’ve been encountering an issue with the screen sharing feature in KDE Plasma, and I’m hoping someone here can help me troubleshoot it.

Background: I’m using KDE Plasma on Ubuntu 22.04, and I often need to share my screen during online meetings and presentations. However, recently I’ve noticed that the screen sharing feature isn’t working as expected.

Issue: When I try to start screen sharing, either through the built-in feature or using third-party applications like Zoom or Microsoft Teams, the screen sharing session begins but the shared screen appears blank or frozen to the participants. I can see my screen perfectly fine on my end, but others can’t see anything or see only a static image.

Troubleshooting: I’ve tried a few troubleshooting steps, including:

  1. Restarting my computer and the screen sharing application.
  2. Checking for updates to KDE Plasma and relevant drivers.
  3. Adjusting screen resolution and refresh rate settings.
  4. Testing screen sharing with different applications and on different networks.

Observations: Despite these efforts, the issue persists. Interestingly, screen sharing was working perfectly fine until a recent update to either KDE Plasma or Ubuntu. I’m unsure if the problem lies with my system configuration, a compatibility issue with KDE Plasma, or a bug introduced in the recent update.

Request for Assistance: If anyone has encountered a similar problem or has suggestions for troubleshooting steps, I would greatly appreciate your insights. Additionally, if there are specific logs or configurations I should check to diagnose the issue further, please let me know.

Any help or guidance would be highly appreciated! Thank you in advance.

1 Like

Is there anyone who can help me with this? I would love your guidance!

Sorry, I don’t know enough about screen sharing to help. I’ve had an issue in the past where Firefox captured just the first frame of my video and then never updated it, but never figured out the cause and now can’t reproduce it anymore either.

I hope someone from the KWin team sees your message and knows enough about screen sharing internals to help out.

@joeroot first things first, are you on X11 or on Wayland?

I’m seeing this issue as well, just in the last couple weeks.

@Zamundaaa , I’ll reply with my details, as it seems @joeroot has dropped off -

  1. Wayland.
  2. I noticed, with the KDE 6 update, that I had to click through the screen-sharing selector twice, as someone else observed in this issue.
  3. Starting a week or two ago, the “share” button in the screen-sharing dialog is grayed out, no matter what option I choose. Sometimes I can click it on the first screen, but then others just see the black screen that @joeroot mentioned.
  4. I’m running KDE Neon, everything recently updated.

Are the apps you’re screen sharing from using X11 or Wayland?

I guess I’m not sure? I’ve tried any/all apps, and none of them allow it. (They used to.) It’s Google Meet that I’ve specifically been trying.

This is what I’m seeing - note the grayed out “Share.”

I’ve also confirmed, through further testing, that this is not application-specific; it happens on Google Meet in both Chromium and Firefox, and Slack (which I assume is using a Chromium browser underneath).

Quite possibly 481461 – Clicking checkbox to select content to share does not work.