Font Viewer for Plasma 6.0.2 not installing Fonts


I am currently using KDE Neon, and just upgraded to Plasma 6.0.2 and I’m having a problem with Font Viewer.

Previously I would open a font, click “Install…” and it would ask Personal or System and proceed to install.

After the upgrade, I open a font, click “Install…” and nothing happens.

Can someone please help me and check if this is a new bug for the new Plasma or if it’s from the upgrade?


i’ve always just selected the font files in dolphin from downloads or wherever and dragged them into the font manger window.

even tho the names might appear in the font manager, you still have to at least logout for the fonts to become available in your apps.

if you can’t even get the names to appear in the font manager, check to see if you have the right permissions on the font files…some times they come over locked and i’ve needed to change them.

Thanks for your reply, but the problem is with Font Viewer:

The install button stopped working.

ah, i’ve never done it that way, but i tried it just now with a random font download and it worked

only i had to reboot in order to see the font listed in the font management tool, where if i drag and drop it would be listed immediately (iirc) even tho i still needed to reboot before i could use it in an app.

i would suggest filing a bug report using the help menu in the font view app.

when I install (I am mostly installing locally ) I only have to restart the app that I’m using (Inkscape).

Well, I’m not having much luck, the functionality of making a bug report using the help menu is also not working… it does nothing :joy:

I don’t know if this will help, but it solved a font issue I was having due to a conflict.

sudo pkcon remove neon-ubuntu-advantage-tools

I confirm the same problem on Manjaro/Plasma6.0.2/Wayland.

been having the same problem aswell under endeavouros/plasma 6.0.2/wayland

iv been using gnomes one instead for now lol

1 Like

Thanks for creating the bug. The reporting bug from the help menu is also not working for me.

Looks like that bug report is now fixed, too!