How do I get this old wallpaper plugin working on Plasma 6?

Here is the link: https://github.com/linlinxza/smartER-video-wallpaper

I changed the desktop file to being a json file after seeing an example. But I don’t know how to make the UI work so that I can select a video. Does the code have to be changed? Or, can I simply make it work again by just adjusting what libraries are imported in the qml files?

For reference, I just scored 60 percent on a Java course while in school. So, my coding skills are very weak. I have a better grasp on computer networking. So, I am hoping someone who knows better can shed some light on how to make this plugin work again.

Anyone? Please? Can anyone help with this?

It has to change I think.

The author already made some changes to the module to improve Plasma 6 compat.

It might be most of what was needed.

The best you can do to port this over would be to have a look at what was done for the others wallpaper modules:

Looking at what changed should help:

And the metadata:

It shouldn’t be much.
You can already try installing the plugin.

There is some porting aid for plasmoid but it should not be applicable here Porting Plasmoids to KF6 | Developer

Hi. I am giving a try to porting it got video working on the settings preview already so hopefully can finish it soon.

That’s better than me. Short of replicating what is done in the json file, I have no clue on what I am doing.

Here’s the initial working version

Okay. So, I copied it over to plasma ~/.local/share/plasma/wallpapers/ and the UI seems to work. Now how can we get it to play video?

I tried the install.sh method. Didn’t work and just gave me this:

-- The C compiler identification is GNU 11.4.0
-- The CXX compiler identification is GNU 11.4.0
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/bin/cc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
Plugin Id: com.luisbocanegra.smart.video.wallpaper
Version: 0.1.0
CMake Error at CMakeLists.txt:21 (find_package):
  By not providing "FindPlasma5Support.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "Plasma5Support", but CMake did not find one.

  Could not find a package configuration file provided by "Plasma5Support"
  (requested version 6.0.0) with any of the following names:

    Plasma5SupportConfig.cmake
    plasma5support-config.cmake

  Add the installation prefix of "Plasma5Support" to CMAKE_PREFIX_PATH or set
  "Plasma5Support_DIR" to a directory containing one of the above files.  If
  "Plasma5Support" provides a separate development package or SDK, be sure it
  has been installed.

So, I just copied the ‘package’ folder over to ~/.local/share/plasma/wallpapers/ and then renamed the ‘package’ folder to the ID ‘com.luisbocanegra.smart.video.wallpaper’ in the json file.

That worked. Just can’t play any videos yet.

Try switching back to image wallpaper, close the wallpaper settings window then run journalctl -f, open the wallpaper settingsagain and change back to smart video wallpaper and check if there are any errors or attach them here/gist/ or issue in the repo

Says this:

file:///home/user/.local/share/plasma/wallpapers/com.luisbocanegra.smart.video.wallpaper/contents/ui/QuickPreview.qml:35:9: Cannot assign to non-existent property "autoPlay"

I think something is wrong in my environment or some compatibility packages are making it work on my computer by using Qt5 things instead of just qt6 since that autoPlay property is indeed not in Qt 6.2+. I tried a clean Arch installation in a vm and can reproduce the error there. Will finish the porting there thank you.

Yeah. We need to let go of Qt5 now as Plasma has moved primarily to Qt6.

Please pull the latest commit and try again, I think it should work now as I removed everything from my system except plasma and was able to reproduce your error.

Note that things like the seekbar or enabling sound don’t work yet

Here’s an example of what’s happening on my end: Video black screen on desktop · Issue #1 · luisbocanegra/plasma-smart-video-wallpaper · GitHub

I can move the ‘package’ folder to ~/.local/share/plasma/wallpapers/ and then rename it to com.luisbocanegra.smart.video.wallpaper. Then that is the result I get.

Okay please upload the log in the issue, we’ll continue troubleshooting there please

Alright then. Got it.