How to reduce the size of a panel?

Hello everyone,

My system:-
Distro: Q4OS 5.2 Aquarius
OS: Debian GNU/Linux 12
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8
Graphic Platform: X11
Dolphin Version 22.12.

I personally find the size of the panels disproportionately large.

System Settings panel (as shown in the Screenshot).

This panel is minimized already and is presently not responding to mouse actions for further decreases of the panel.

Is it possible to reduce reduce the size of this panel any further (say to the size of the calendar panel minus the bonded Time Zones panel)?

Calendar panel (as shown in the Screenshot).

If it wasn’t for the Time Zones panel, the size of the calendar panel by itself would (in my view) just about acceptable.

Is it possible to either reduce the size of the panel or alternatively do away with the bonded Time Zones panel completely? Thanks.

in the digital clock settings you can turn off timezone displays in the pop out by only having the one timezone in the list.

but if you then turn on the PIM addon then instead of timezones in that space you will see your appointment schedule

as for the overall size, they look the same as on my 1080p monitor… there may be display scaling tricks you can do, i’ve not played around with it.

Right-click on the panel and click Enter Edit Mode. Then resize the panel.

Thanks for responding.
I prefer the time zones display when scrolling over the clock applet and rather leave the digital clock as is. As for scaling, my system is cannot be scaled down only up.

I tried that - there is no Enter Edit Mode when right-clicking on the panel

Under More Actions is a Resize Option but it won’t decrease to my desired size.

Are you right-clicking on an empty area?

Yes, I right-click an empty area within the System Settings panel. Neither right and/or left click show Enter Edit Mode.

Sorry, I thought you were talking about the Plasma panel. You’re talking about headers in applications. That would require editing the actual source code as the heights are defined in there and re-compiling.

Many, many moons ago when netbooks where fashionable I recall that there used to be a keyboard short-cut for reducing the size of a panel; It was essential in some instances as the minimized panels were still too large for the relative small netbook screens.

I just about tried every possible combination - maybe this particular keyboard short-cut has been rendered as obsolete.

There was a time when configuring the height of System Tray proportionally to the icons was a pain in the neck. One had to access and configure the main.xml file which was a nerve wrecking exercise. Nowadays you activate the radio button ‘Scale with Panel height’ that’s it - as easy as pie.

Anyway, the KDE desktop environment is constantly evolving and the developers may one day consider for introducing a user-friendly way for decreasing the size of System Settings panel and other.

only up

precisely why i haven’t played with it… sounds like the opposite if what i’d want to do with a 1080p monitor.

but what if it makes your 1080p render like it’s a 4k monitor? everything would “shrink”, no?

just a thought.

they’re not actually panels like the ones you can add by right clicking… they are popups (or at least the calendar on is).

no resize option on those like the regular panels.

Looks like you submitted a duplicate thread at How to decrease the size of System Settings and remove the Time Zones from the Calendar, which I have already answered.

Please don’t do that. Duplicate threads fork the discussion and confuse everyone.

I will migrate my answer from there:

At the moment, neither is possible. System Settings has a minimum size that is rather too large ( see 395476 – The minimum window size of System Settings is too big for a 1366x768 screen) and time zones always appear in the Calendar popup when you’ve configured them.

1 Like

Sorry, it wasn’t my intention to make anyone confused. In truth and based on the earlier answers received, I thought my original post lacked clarity and was directed to the wrong Category.

Thank you for the information provided in regards to my questions.