How to set Qt5 font size

While upgrading to Plasma 6 all my Qt5 apps don’t follow the system settings font dpi.

Apps like pcmanfm-qt or qt4wine.

Do you know any alternative way to set it?

Which distribution are you using?

It sounds like you are missing the Qt5-variant of plasma-integration

Even the cursor looks different.


That is also explained my missing plasma-integration

For now only packages needed by Qt5 apps are retained after upgrading, but to keep qt5 integration including cursor, theme and fonts there is no clarification from KDE of what we need to install or remove.

Plasma/Plasma 6.0 Release notes - KDE Community Wiki clearly states that a Qt5 build of plasma-integration is needed. If your distro does not provide that by default you need to get in contact with them


You are right, Arch had two packages plasma-integration and plasma5-integration and installing the latest seems to fix the cursor.

Just to be sure, so if we have Qt5 apps installed, we only need the following packages to have full integration with new Qt6 desktop settings?

1 Like

yes, that should be enough

1 Like

That fixed the issue, thanks! :ok_hand::wink:

I just installed:


As kwayland is already a dependency of plasma5-integration, and oxygen5 is rarely used.

I also installed kwayland-integration, as the documentation states it should be included for compatibility with Qt5 apps.

I’m having this problem on both arch linux and fedora 40 Kinoite, both with all the packages installed that are said to be the fix for this cursor problem, but neither is solved.

  1. Being in your home folder, press “Control + H” to show hidden files.
  2. Go to the folder “.config”.
  3. Open the file “kdeglobals”.
  4. In all the lines that list a font, remove all the numbers except the first one. And save.

That doesn’t work either

The cursor looks fine on 3 laptops running Plasma 6.0.1 with the same Manjaro unstable (synchronized with Arch stable), so to isolate user configuration issues, can you create a new user and test if the problem persists.