How to Set Up KBanking

I am running the Linux v. 5.1.3 (Correcting typo. Sorry) of KMyMoney.

Under Settings/Configure KMyMoney/Plugins, I have KBanking appearing. I have checked the box next to it. I am unable to edit settings for it or use it. What am I doing wrong?

Thanks for your help.

[I thought I replied by email, but it hasn’t shown up yet - hopefully it wont end up being a dupe]

Hopefully you mean 5.1.3 or else you seem to have a time machine available.

The checkbox in the plugins section of the configuration dialog simply enables the feature. I don’t use it, but as far as I know, any configuration happens when you map an account to an online account. When you do that (Account/Map Account… menu item) you should get a dropdown with all the possible online plugins, which should include KBanking (and probalby also the OFX based on libOFX.) If you choose KBanking there, I believe you will see the relevant options. Then, once you have the account mapped, editing the accounts should include a tab for Online Settings.

Do you see the menu item Settings/Configure KMyMoney/Configure AqBanking ? That is, where you setup your online access for the KBanking plugin. Once that is done, you can map your KMyMoney account to this online account as @ostroffjh explained.

BTW: which protocol (e.g. OFX, HBCI, …) do you need to access your bank online?

Unfortunately “Configure AqBanking” does not appear as an option in Settings/Configure KMyMoney (Linux, v. 5.1.3). Have I done something wrong?

My bank provides CSV files which I manually import. I am going to see if I can prevent importing the Memo field (So many new things to learn! It’s fun.)

My credit card company provides QIF files which I can manually import.

Thank you very much for the help.

In case the Configure/AqBanking menu item does not appear, you probably have not installed the AqBanking package and its companion Gwenhywfar. Those are packages also used by other finance programs e.g. GnuCash.

I have not used the 5.1.3 version for a long time (I live on the bleeding edge) but can’t you create a CSV profile where you don’t assign the memo column so that it is not imported?

Thanks for the suggestions. I installed AqBanking and Gwenhywfar, but still no joy. Nothing shows in the configure window. :slightly_frowning_face:

I tried reinstalling KMyMoney afterwards, but it made no difference.

What distribution are you using? Did you install KMM from their package manager, or some other way? If their version is not handling dependencies correctly, I would suggest posting to one of their forums or mailing lists.
In the meantime, have you tried launching KMM from command line to see if there are any errors output to console?
Separately, have you tried using an Appimage? https://kmymoney.org? the BEST Personal Finance Manager for FREE Users, full stop. | KMyMoney

I tried your suggestion to open KMyMoney it via the terminal. The result was a whole new installation of KMyMoney. I went ahead and set up a new file using it. THAT installation worked for KBanking and AqBanking. I then saved it to use next tax year (2024).

I closed it and opened this year’s file I have been working on up until now. Although I have not yet tried it, the AqBanking importer shows up under /File. Progress! :slightly_smiling_face:

Thanks for your help, everyone. I’ll let you know how it works.

Again, please let us know which distribution you are using, and where you installed KMM from. I can not think of any way that running the program from command line/console would create a new installation. Why you think you have a new installation, and how does it differ from the original one?
On a totally separate note, why do you create a new data file for each year? There are some of us with more than ten years of data in our files, and performance is still perfectly acceptable. You can easily filter ledgers to not show any data prior to 1 Jan of the current year, and most (all?) reports have current year only options.

I’m using Kmymoney 5.1.2 on Kubuntu 22.04 since nearly two years with success. And I’m also able to do online banking with the Kbanking module and Aqbanking.
Some days ago I found a new version Kmymoney 5.1.3 on
Install KMyMoney on Kubuntu using the Snap Store | Snapcraft” which I thought to be useful for me, because I had some trouble with investments, online price quotes and online currency updates etc., and I thought the new version would provide some improvements on this topic.
Installing with “sudo snap install kmymoney” worked, and I can start Kmymoney 5.1.3, but it does not show Aqbanking under settings, similar as reported already in this topic and elsewhere for a MacOS-system:
KMyMoney V5.1.3 for MacOS 5.1.3 with KBanking plugin not showing Aqbanking under settings.
Opening my old “bankingfile.kmy” worked and I see all my bank accounts, transactions and bank postings, but online banking is not possible anymore.
Reading the various discussions on this topic, I think the Kmymoney snap package cannot find the AqBanking package.
I started Kmymoney 5.1.3 in a terminal and found the following passage in the output list:
<
Loading “/snap/kmymoney/2/usr/lib/x86_64-linux-gnu/qt5/plugins/kmymoney/kbanking.so”
“Plugins: kbanking loaded, build with (5.10.1stable-0/6.5.4.0stable), run with (5.10.1.0/6.5.4.0)”
3:2023/11/28 20-01-39:gwen(404984):plugin.c: 401: Plugin “dir” not found.
3:2023/11/28 20-01-39:(null)(404984):banking_cfg.c: 75: Could not create ConfigMgr[dir:///home/user/.aqbanking/settings6]. Maybe the gwenhywfar plugins are not installed?
7:2023-11-28 20:01:39:aqbanking started
3:2023-11-28 20:01:39:aqbanking banking_init.c: 403: No config manager. Maybe the gwenhywfar plugins are not installed correctly?
7:2023-11-28 20:01:39:aqbanking stopped
Could not initialize KBanking online banking interface

Since I’m not familiar with the snap data structure and the dependencies, I don’t know what to do now.
Thanks for your help.

I am not familiar with the snap creation process myself but it seems, that the option --enable-local-install may have been missing when building the gwenhywfar package for the snap. I added the following to the AppImage build instructions in September to make it work:

    # For appImage builds the --enable-local-install is needed so that
    # the appImage is searched for gwenhywfar plugins
    if CraftCore.compiler.isMacOS or CraftCore.compiler.isLinux:
        self.subinfo.options.configure.args += ["--enable-local-install"]

Maybe, that helps the snap creator (@scarlettmoore if I am not mistaken)

@HSpri
I have no clue about snap.
I know a way to get both online banking and the Version 5.1.3 of kMyMoney: use the AppImage version of the software instead of snap.

I am using it on a ubuntu-like distro since a few months.

@surcouf
Thanks for your hint. I tried the AppImage version with success. I think, I will use it till the next regular update for Kmymoney will be provided in the Software Center for Kubuntu 22.04.
(Actually they offer only Kmymoney 5.1.0).