I'm blocked at the kde log in screen (which doesn't have its usual appearance), after I updated my KDE Neon

Yesterday, I updated KDE neon normally with Discover. But after restarting my computer, I’m blocked on this login screen (and the appearance of the log in screen has changed, because I’ve never had a login screen with this appearance before)


.
https://imgur.com/a/ZekiZs2
And when I type my password, the screen goes black for a second, then redisplays the login screen. And if I retype my password, the same thing will happen again. So I can’t log in.
I have tried different solutions explained on this forum that have worked for some people, but nothing has worked for me. (I tried to do things in the terminal using Ctrl + Alt + F2)

https://imgur.com/a/j0ByyKE
(I did not only try to solve the problem with the commands shown in the photo, but I also tried other commands)
And I don’t know if the result of this command is useful to know how to fix the problem, but I’ll show it anyway just in case

https://imgur.com/a/86aBaG2
And when I type kf5-config --version, I have :
Qt: 5.15.12
KDE Frameworks: 5.115.0
kf5-config: 1.0

How can I log in to use my KDE neon again?
I’ve spent a lot of time trying lots of things, but nothing works.
Thank you very much for your answers

Same login screen here, but I can login and get to normal desktop. Everything else seems to be working ok.

It looks like an incomplete upgrade, not the ‘... 36 not upgraded’. It also looks like it is caused by not being able to install the new version of libxmlb2, which in turn blocks other packages. I had a similar issue, although with a different package.

What I’d try first is check what sudo apt install libxmlb2 tells you. I expect it will come up with a list of things that need to be removed before libxmlb2 can be upgraded. Check that list contains anything essential, if not continue. After that run sudo apt full-upgrade to try to complete the rest of the installation. That might get stuck again on something else, on my system I needed to run sudo apt install plasma-desktop plasma-pa kde-style-oxygen libsdl2-2.0-0 libdecor-0-0 to get the last packages in place.

If you get other errors or it looks at any point like it’s going to remove things that should not be removed check back here with whatever you got. I’d also be careful running apt autoremove before everything is working again.

Op should also probably update the database before running an upgrade.
Ie, run sudo apt update first.

1 Like

Good point, do that first. Even if it’s not needed it won’t hurt.

Thank you very much for your reply.
I ran sudo apt update, and then sudo apt install libxmlb2 and it said “libxmlb2 is already the newest version”.

Then I ran sudo apt full-upgrade.

and after having finished, I turned off my computer. Then I turned it on, but I still have the same problem, I’m stuck in the log in screen.
so I ran sudo apt install plasma-desktop plasma-pa kde-style-oxygen libsdl2-2.0-0 libdecor-0-0 as you said. But it says “you have held broken packages”


One package seems to be causing problems.
What can I do ?
Thank you

That’s a problem, the version shown there is the original Ubuntu version, not the updated version from Neon. This might be because it got marked with hold. You could try: sudo apt-mark unhold libxmlb2. You could also try asking for the correct version specifically: sudo apt install libxmlb2=0.3.15-0xneon+22.04+jammy+release+build6. If that seems to have done anything useful you could try running sudo apt full-upgrade again.

If that doesn’t work I’d like to see what apt-cache show libxmlb2 | grep Version tells you, as well as dpkg -l | grep libxmlb2 and dpkg -l | grep libappstream5 to see if that clarifies anything.

I ran sudo apt-mark unhold libxmlb2, but it says it’s not on hold


Then I ran sudo apt install libxmlb2=0.3.15-0xneon+22.04+jammy+release+build6, but it’s says there is a problem with the version

then I ran sudo apt full-upgrade just in case But I still have the same result as before

Then I ran apt-cache show libxmlb2 | grep Version + dpkg -l | grep libxmlb2 + dpkg -l | grep libappstream5. But dpkg -l | grep libappstream5 produces no result.

Thank you for taking the time to reply

Something about apt is incorrect on your system somehow. Here’s what I got:

$ apt-cache show libxmlb2 | grep Version
Version: 0.3.15-0xneon+22.04+jammy+release+build6
Version: 0.3.15-0xneon+22.04+jammy+release+build5
Version: 0.3.14-0xneon+22.04+jammy+release+build4
Version: 0.3.13-1xneon+22.04+jammy+release+build2
Version: 0.3.13-0xneon+22.04+jammy+release+build3
Version: 0.3.10-2+22.04+jammy+release+build1
Version: 0.3.6-2build1

You are missing the newer versions. You could run sudo apt update and try again just to be sure, but I doubt that’s the issue.

Can you check cat /etc/apt/sources.list.d/neon.list? I’d expect this output:

deb http://archive.neon.kde.org/user jammy main
deb-src http://archive.neon.kde.org/user jammy main

Looking at your previous apt update output it looks like it is fetching that Get:4 http://archive.neon.kde.org/user jammy InRelease [189 kB], so I feel it should also find that 0.3.15 version. It is also fetching 32bits (i386) and DEP-11 stuff I’m not seeing on my system. There could be something there which interferes, although I think it shouldn’t.

Perhaps apt-cache policy | grep neon or apt-cache policy | grep libxml tells us something more.

I checked cat /etc/apt/sources.list.d/neon.list And I think I got the output you expected.


Then I checked apt-cache policy | grep neon and apt-cache policy | grep libxml .
And I got this

That last one indicates that libxmlb2 has been ‘pinned’ to a specific version, which would explain why it’s not being updated. I don’t know why that happened but using grep -iR libxml /etc/apt/* you should find the file where this is configured. I’d expect to find a file in /etc/apt/preferences.d/.

Depending on the file you find you could edit it and comment out the lines related to libxmlb2 (using #) But perhaps it’s easier to just move that file out of the way (don’t delete it just yet) if it appears to be something old. But note that 50-neon-ubuntu-release-upgrader, 99-jammy-overrides, 99-neon-base-files and org-kde-neon-net-launchpad-ppa-mozillateam-pin are supposed to exist and should not be removed. If in doubt just post here which file it is and what is in there.

After that and try both sudo apt update and sudo apt full-upgrade again.

I typed grep -iR libxml /etc/apt/* And I got this result

How can I comment out the lines related to libxmlb2 using # ?
And how can I move the file out of the way ?
I don’t know how to do these things
Thank you for your patience

Can you check using ls /etc/apt/preferences.d/ if that shows a file named 99-jammy-overrides? Starting with 99 instead of 98. I guess this file is an old version and only 99-jammy-overrides should exist.

If that is the case you can move this file away using sudo mv /etc/apt/preferences.d/98-jammy-overrides ~, which will move it to your home directory.

Thank you, you’ve solved my problem
I typed ls /etc/apt/preferences.d/ And as you’d expect, it starts with 99.
So I typed sudo mv /etc/apt/preferences.d/98-jammy-overrides ~


Then I typed sudo apt update and sudo apt full-upgrade.
I switched my computer off and on again, the login page is the same as for KDE 6, my password gave me access to my kde plasma session, and kde plasma is working well and normally. In short, everything works fine, the problem is solved.
Thank you !

Is not a better solution to reinstall intead of trying lots and lots of commands? And, is this going to happen again?