KDE Online Accounts - Not Signing In

I’m trying to add Google as an Online Account in System Settings. This is a fresh install of Kubuntu 23.04. I’ve attempted adding Google as an online account via the System Settings and through Dolphin. I have tried it with KIO GDrive uninstalled, and with KIO GDrive installed. I get the pop-up box (web authentication for Google) asking me for my e-mail address. I input it and press enter (or click “next”) and the little blue bar moves from left to right across the box, but it never prompts me for my password or does anything else. It never times out either, it just sits there with the little blue bar moving. I can leave it for hours or days, but it still never progresses beyond this, and neither does it give me any error messages.


I have this same problem, it is affecting all distributions that I have tried which are shipping with plasma 5.27.6

Currently I am test this on KDE Neon in virt-manager, however previously I have installed:
MX Linux 23.1 KDE
Solus 4.4 KDE

On hard metal and get the same result when attempting to sign into Google via Online Accounts.

It sounds like you’re suffering from 420280 – Google authentication process gets stuck due to excessively old version of signon-ui library. It’s a known bug caused by your distro shipping an excessively old version of the signon-ui library. They need to fix that. There is nothing KDE itself can do here; it’s up to your distro to fix their packages.


Hi, thanks for the reply. I will keep my eyes peeled for a fix.


I have a similar issue, I go to System settings> Online accounts> Add new account but the google account option doesn’t show up. Is there a fix?

I am quite new to the KDE Plasma distro and community and I log in to check if it’s only my problem :). I installed kaccounts-providers, kio-drive and after tapping google account login it stacks, and at last shows the same error as above mentioned. Any view to solve this problem in the future ?

Just an update on this, I am using Solus with KDE Plasma, after the week 38 update I am now able to log in to online accounts Google Drive.

This is what the dev said:
Yeah, that working was a side effect of me modifying signon-ui to use qt5-webengine instead of qt5-webkit. Honestly I didn’t even realize it didn’t work before but I’m glad it’s working now. Thanks for noticing that it’s been fixed

How did you fix it? Fresh install of Kubuntu 23.04 and the same problem.

There is no (easy) way for you to personally fix it. It’s up to the Kubuntu folks to fix it by shipping an updated version of the software library that’s broken here.

Oh ok. I thought he mentioned that he was able to login finally.

I did not fix it, the devs at Solus fixed it inadvertently.

Read my post again - KDE Online Accounts - Not Signing In - #7 by bubba66

Thanks for your reply. I can read again but I don’t know what Solus is and I’m new to Linux and KDE so probably misunderstood.

As you are new to Linux I will explain, Solus is an independent Linux distribution that provides the KDE Plasma desktop as one of the downloadable options - Download | Solus

Nice! Thanks a lot. Unfortunately my experience with Linux hasn’t been smooth so far. I get flickering monitor periodically on my laptop, probably because Nvidia :frowning: I’ll take a look at Solus. :+1:

I’m just a newcomer on kubuntu 23.04 and can’t log in to my google account from system settings.
I’ve been searching all around and it seems nobody feels it’s worth solving this issue or just blames the distro or the desktop, each maintainer blames the other one.
On the main pages of each website (kubuntu and kde) they list all features and advantages of using their products, but at any complain referencing this issue, it’s easy to find someone shouting " this is an open source volunteer project and you don’t have the right to complain .
This topic isn’t solved -at all- at least on my distro, and is marked here as a fault on kubuntu maintainers. And kubuntu blames it on kde based on -I can’t understand- some kind of deep technical issue as gnome version of ubuntu works flawlessly.
I’ve lost all hope to get a solution or workaround, at least for those users -like me- that aren’t used to the subtle details of the Linux language, but I feel a little bit released after writing this -useless to anyone else- post.
Thanks for reading and “wellfind” to anyone on this forum.

Where exactly are the Kubuntu people blaming us? Can you point me to a link?

I had the same problem, very frustrating.

Try Linux Mint. It doesn’t have this problem

Hi, I have same problem on Kubuntu 22.04, 23.04, 23.10.

I installed ubuntu server edition and installed kubuntu package on it.
I also tried ubuntu-server + ubuntu desktop too.

Result is, all Kubuntu can’t use online-account feature.
BUT normal Ubuntu can use it!

I found this article which @ngraham posted.
I hope it will be solved in near future…


I’m seeing these symptoms on Fedora 38. It appears that the signon-ui package that Fedora ships is up-to-date?

rpm -qa | grep -I -d skip -D skip signon

The package info leads me to the package homepage: Online Accounts: Sign-on UI in Launchpad. Version 0.15 is the latest there.

If I have the latest version of signon-ui, should this be reported as a bug?

I’ve reported a bug for Fedora for investigation there: 2248688 – Google Account Sign-on hangs and can never complete