KDE Plasma 5.27 desktop freaks out!

As pointed out here

Kubuntu 23.10 got “KDE Plasma 5.27 desktop”.
But there’s a little problem:

Any ideas ?

Thank You for Your support !

1 Like

Did you post this in the Ubuntu forums?
Are both DEs (Plasma and GNOME) installed in the same operating system or are these two seperate systems?
Do they use X11 or Wayland?
How is the memory configured (e.g. vm.swappiness and vm.vfs_cache_pressure)?
Is there a difference in running processes (apart from the DEs)?

At least my Kubuntu 23.10 (de-snapped, with Kubuntu Backports, 32 GB RAM) and another Kubuntu 23.10 in a VM (with Snaps, without Kubuntu Backports, 4 GB RAM) don’t do that - and there have not been any reports of this behavior in the Kubuntu Forum .Net so far…
Neither does my openSUSE Tumbleweed or my Debian 12 or my TUXEDO OS (all with Plasma 5.27.x and more or less up-to-date system components).

Generally speaking on all of my computers KDE Plasma does use a lot less memory than GNOME does…

I’m sorry, but I’m just pointing to a FACT !

Did this already, as You knew if You read my post . . .

Plasma 5.27 on FreeBSD neither…

Physical  : [###############################....] 89%   (14125/15810)
Swap      : [###################################] 100%  (4096/4096)

@schwarzerkater :

Thank You for looking at the problem seriously . . .


The same Kubuntu 23.10 base, Gnome installed on top of it.

KDE and GNOME are starting via X11 and Wayland correctly.

Did not change the default-behavior.

KDE got running widgets that are just showing text i.e. for CPU-load instead of also showing changing bars - I’m using INTEL on-board-graphics(i915).
(Original install of Fedora36 KDE-flavour on the same system showed correct widgets, behaviour changed to “just text” after an upgrade then . . .)


Just READ my post:
Starting Ubuntu with Plasma-DE and just 1GB of swap, memory and swap are filled rapidly until system becomes ABSOLUTELY DEAD !
So for TESTING I added 50GB of swap and as expected time for filling this is longer :wink:

Your config is obviously good then. It must be a KDE issue. I’ll stay out of the way. Sorry again.

^^^ this might be something to consider.
Installing Gnome on top of Plasma, or vice-versa, is known to potentially be problematic in odd ways. Especially if one used a more complete meta-package such as ubuntu-gnome-desktop (or kubuntu-desktop, in the other direction).

Duplicated or competing services running at login, and other things like this. Add to this to some systems having a propensity to hit the swap early, which may be aggravating things as well by slowing everything down significantly.

You might also have a specific item with a memory leak. You may need to use a system monitor to hopefully catch what is spiking the memory usage.

1 Like

Did the “memory leak” also occur before you installed GNOME on top of it?

So this problem occurs both in KDE Plasma X11 and KDE Plasma Wayland?

Do you use third-party widgets? Or complete third-party themes?
Regardless - I would disable all of the widgets, reboot and see if it changes anything…

Better would be, if you could also try using e.g. something like htop and try to find out what exactly the culprit is.

Another - more broad - test: does this also happens when booted from a Kubuntu 23.10 live USB stick (yes, there is no swap partition, but you can simulate your work load and observe the memory behavior…).
If it does not, a simple solution could be to backup the user data and go for a new installation from scratch.

PS: You could also create a new user and see if it also happens there.

1 Like

@claydoh :

Don’t think so as Kubuntu 23.10 filled memory BEFORE I installed GNOME to be able to use Ubuntu at all . . .

Installed “htop”, which stops working when starting Plasma . . .

That was not stated earlier. This helps rule out some things, and hopefully narrow things down, at least a little.

Some more things to try, or look at:
disabling desktop search (not likley, but easy to eliminate)
disabling desktop session restore -set it to start with an empty session
Clear your ~/.cache
Create a new user account , maybe there is something broken or corrupted in your account
If using any panel or desktop widgets, remove those

It smells like a memory leak, but you will have to look more closely at what specific process is sucking up all the memory.

what @claydoh says.

as follow up: also check the autostart section in your kde systemsettings on your account.

I still think starting top or htop from konsole could also give useful hints what’s littering to your memory.


(Infact I don’t like to use Gnome or Unity . . .)


Luckily I got no data to backup, BUT 2 fresh installations of Kubuntu 23.10:
1 on INTEL RST RAID1 onboard
1 on Seagate 80GB SATA2 Hdd at Asmedia SATA3-HA in PCIe-Graphics-slot

Thank You schwarzerkater !

Thank You claydoh !

Removed Network-, Harddisk-Usage- and CPU-Usage-Widget from desktop and filling up memory stopped !
So my Kubuntu with i915-graphics is fine now WHITHOUT WIDGETS ! :+1:

1 Like

the system monitor widgets can be buggy … feel free to recreate it and it would probably be fine.

and if you plan to put them into a panel like this, then go ahead and add them tot he panel first before you edit them because sometimes just the act of dragging them into the panel can cause them to glitch out.


Thank You for Your proposal !

1 Like

‘solid as a rock’???

You could help to determine which one was at fault enabling them one by one and checking how the memory grows, this would help us to fix the issue for other users.

Those plasma-widget are community-maintained and have potentially many users.

I would guess that would be the Hard disk usage one, as I use the network and CPU usage ones myself but did not encounter the same issues as you did.

I won’t use the term “stable,” because that means unchanging, as in a Debian version, but if what I said offends you somehow or confuses you enough to ask about a 3 month old post, then I apologize. Other than that, I don’t understand what you are asking.

As far as I can remember issue was related to CPU-widget . . .
I’m no longer using onboard-INTEL graphics, but reinstalled old Nvidia-GT240 in graphics-slot of my beloved Dell-oldtimer. So all is fine now without INTEL graphics . . .