Kdenlive 23.08.2 released

You gave me an idea when you said two monitors. I just tried changing my Monitor For Fullscreen Output, but no…

Strangely, when I hit the hotkey twice then the windows key twice I’m back in Kdenlive :thinking:

Double click into the clip monitor → it should go to full screen. Double click again into the full screen clip monitor, it should go back into Kdenlive.

That works but the issue is on the hot key (F11) toggle.

i used Kdenlive every day last week without any crash… very happy, usually something happens but this seems a very stable release.

2 Likes

Version 23.08.2

Ubuntu Studio / Ubuntu PPA

CPU: Intel i5 13500 internal graphics.

I have noticed that the Transform and Composite / picture in picture isn’t working in this release of Kdenlive.

Kind regards
Paul

Could you point out where this composition or effect is? I don’t know about picture in picture effect out of the box in Kdenlive.

Or do you use the Composite and Transform composition to scale and move a clip so that it appears as a picture-in-picture? If so, it works flawlessly for me (Kdenlive 23.08.2 installed or as appimage on Pop!_OS 22.04).

Perhaps you can elaborate on

Hi Berndmj, thank you for your reply, yes, I used the Composite and Transform to move a clip over another clip - like a Title Sequence, where the text appears to zoom into the frame, just as you described.

I shall try the appimage version to see if that makes a difference, as that one works for you.

Good, but just to clarify: it works for me also with the installed version (through ppa).

Generally speaking, I prefer just the Transform effect for something like this. It appears to be faster and more flexible … YMMV

1 Like

Hi Berndmj, thank you for your further reply.

The appimage version is indeed working okay with the Composite and Transform, as I downloaded that, and executed the progran or App in the terminal.

I removed the version that is already installed in the Ubuntu Studio, and re-installed it in the terminal, just to see if any issues have been fixed, not fixed, not working.

So, it is always polite to state that the issue is solved in a forum.

I shall try the Transform effect, as you have kindly suggested, from now on in my video post-production projects, thank you for that.

I’ve been using Linux since Fedora 9, by reading the Linux Bible books by Christopher Negus, and I have numerous other Distros too.
But, I prefer a Linux Distro like Ubuntu Studio where all that I require is in one place.

Kind regards
Paul

I looked at that distro, too, for the same reason :smiley:

But I found that it had a lot of stuff for audio recording, working with instruments and so on which I really don’t need. So I continued distro hopping until I came across Pop!_OS, and it ticked all the boxes for me.

1 Like

Hey guys, amazing release!! I just have one question: what do you need to port or create a version for Apple Silicon? The X86 version works quite well, but it is a little noticeable, especially when launching the application, that it is not optimized.

I have updated my bug report by selecting version 23.08.2 from the Version drop-down menu. (This was not available as a selection when the bug report was initially submitted.)

1 Like

People who can code or know how to build for Apple Silicon. Alternatively, a $#!7load of money to hire one who can …

Yup, I had pointed that out to the devs just recently, and while they cannot change it directly they reached out to the KDE folks maintaining that site and asked them to put it in.

KDE is currently undergoing some significant changes, AFAIK, so some things simply fall through the cracks …

Hi, Since I haven’t seen anyone else post the resolution to this yet, but lots of people banging their heads against it:

I assume it’s related to the updates to the kde build farm that were mentioned around the time of the 23.08.2 release. The missing GLIBCXX symbols are because that release’s appimage was built with a newer libc than had been used previously and that ships with Debian 11 and derived distro releases. You’ll need to update to Debian 12 to use this appimage.

HTH,
Ron

Kdenlive build for Apple Silicon ARM is an ongoing task. We are almost there. It will not come before February 2024.

And still no GPU-support… :smile: - I am waiting for this since several years - and I always have to laugh when you release a new version. Guys, we have 2023 - and not 1990 anymore. Your complete work is nonsense without GPU acceleration for encoding, playback + effect generation - are you still working on a 386 ??? I am going to buy a professional program/Davinci now - my dream that you manage this at some point died - you never will manage this. Too bad, but not to change. Without any GPU support, a video editor is completely useless in 2023 in my opinion. Its like driving VW Polo while all the world drives Ferrari :pensive:

Just FYI, @Micha1982: Kdenlive uses the MLT Framework for effects application and compositing. As long as MLT does not support GPU acceleration, Kdenlive cannot offer that. The movit library helps in that regard but is still somewhat limited in scope and acceleration. You can switch it on in the settings.
Encoding is done via ffmpeg, and when you select a codec with HW support the GPU is used, but encoding is not the bottleneck …

… also the kind of people who drive a Ferrari don’t call Volkswagon to yell at them complaining they don’t give away free Ferraris. Just Sayin’

The kind of people who pick up a spanner to work on their VW on the other hand: https://www.youtube.com/watch?v=yMLcdjqZh6E

1 Like

@Micha1982
Apparently you are looking for something other than what is offered here. Maybe you’ll be happy if you buy a video editor.

I am very happy with what Kdenlive can already do. It is a great gift for me and the many thousands of users of the best of all opensource programs.

I don’t need GPU acceleration, my videos are very short. If they were longer, I would wait until they are rendered.

But it’s perfectly fine for you to express your frustration. Everyone is allowed to think what they want.

I think Kdenlive is great, and if a major bug crops up, it usually doesn’t take that long to fix it.