kdenlive-24.02.0_A-x86_64.AppImage doesn't work on porteus 5.01 ( slackware 15 based distr)

I would like to run the apps image Kdenlive kdenlive-23.08.5-x86_64.AppImage but I got

guest@porteus:~$ '/home/guest/Downloads/kdenlive-23.08.5-x86_64.AppImage' 
/tmp/.mount_kdenligWus3m/AppRun.wrapped: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /tmp/.mount_kdenligWus3m/usr/bin/../lib/libicuuc.so.74)

althought usr/lib64/libstdc++.so.6 is here

guest@porteus:~$ '/home/guest/Desktop/kdenlive-23.08.5-x86_64.AppImage'
/tmp/.mount_kdenli83dJCz/AppRun.wrapped: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /tmp/.mount_kdenli83dJCz/usr/bin/../lib/libicuuc.so.74)
guest@porteus:~$ whereis libstdc++.so.6
libstdc++.so.6: /usr/lib64/libstdc++.so.6

So I tried kdenlive-24.02.0_A-x86_64.AppImage
but it doesn’t foud neither /usr/lib64/libgcc_s.so.1 neither /usr/lib64/libstdc++.so.6

guest@porteus:~$ '/home/guest/Downloads/kdenlive-24.02.0_A-x86_64.AppImage' 
/tmp/.mount_kdenlizaSv7R/AppRun.wrapped: /usr/lib64/libgcc_s.so.1: version `GCC_12.0.0' not found (required by /tmp/.mount_kdenlizaSv7R/usr/bin/../lib/libQt6Gui.so.6)
/tmp/.mount_kdenlizaSv7R/AppRun.wrapped: /usr/lib64/libgcc_s.so.1: version `GCC_12.0.0' not found (required by /tmp/.mount_kdenlizaSv7R/usr/bin/../lib/libQt6Core.so.6)
/tmp/.mount_kdenlizaSv7R/AppRun.wrapped: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /tmp/.mount_kdenlizaSv7R/usr/bin/../lib/libQt6Core.so.6)
/tmp/.mount_kdenlizaSv7R/AppRun.wrapped: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.30' not found (required by /tmp/.mount_kdenlizaSv7R/usr/bin/../lib/libicuuc.so.74)

althought they are here

guest@porteus:~$ whereis libstdc++.so.6
libstdc++.so.6: /usr/lib64/libstdc++.so.6
guest@porteus:~$ locate libstdc++.so.6
guest@porteus:~$ whereis libgcc_s.so.1
libgcc_s.so.1: /usr/lib64/libgcc_s.so.1
guest@porteus:~$ locate libgcc_s.so.1

How can I run kdenlive app image on my system?

I have the same problem, Appimage on Linux Mint 20.3 does not start, same error messages as above.
“GLIBCXX_3.4.29” and “GCC_12.0.0” not found.
I thought, the Appimage has no requirements (according to the documentation:
" Kdenlive on Linux[¶]
Kdenlive can be installed on non-KDE Desktops without any issues.

Packages: Minimum Ubuntu 22.04 for PPA. AppImage, Snap or Flatpak have no such minimal requirements."

Any ideas how to make the appimage work?

The problem isn’t that you’re missing libstdc++.so.6, it’s that your distro has an ancient version which is missing symbols the Appimage needs.

You either need to update your distro, or use an older appimage.

Thank you very much for that fast answer.
Not exactly what I wanted to read ;-), but I wanted to upgrade to Mint 21 anyways. So it’s going to be a bit earlier.