Kio-gdrive hangs when adding a new account


I was really enjoying KDE Neon’s built-in Google Drive integration (kio-gdrive) on my new work laptop, until it suddenly stopped working.

Now, when I even try to log-in to my Google Account through System Settings > Online Accounts, it hangs the moment I type in my email. I have had some people suggest this is an issue on Google’s side, but if it helps I’m using 23.04.3-0xneon+22.04+jammy+release+build18 .

Thx in advance

1 Like

I’m trying to set this up for the first time on a fresh install, getting something somewhat similar. Did you ever find out what was causing your issue, and how to resolve it?

My question: KDE Online Accounts - Not Signing In

It sounds like you’re suffering from 391186 – [kio-gdrive]Access token expires/invalidates after performing a few file operations for the GDrive thing, and then when you try to log in again, you hit 420280 – Can't add Google account: authentication process gets stuck.

These are known bugs and nobody’s fixed them yet, unfortunately.

1 Like

2 weeks later I get this error for device activity at 4 AM this morning.

It doesn’t even say what app, is it just not able to understand kde-gdrive?

Probably, but I don’t know for sure.

The whole situation is very sucky. Google changes the way their 3rd-party authentication system works at random, with no warning and no documentation about it. We adapt to it, and then it breaks again.

It’s pretty clear they want you using their websites and apps rather than 3rd-party clients.

I would personally recommend migrating away from Google services to whatever extent it’s practical for you.


Again, this is a work computer. And our workplace likes Google.
Had this been a personal cloud service, sure, I’ll do it on the dime. But that’s not possible so I might as well contribute to getting Drive working on KDE.

It’s a shame that Google’s own developers will comply with propertiary OS’ (Microsoft and Apple) demands and maintain working versions of Drive for Win/Mac, but then will gatekeep distros like this.

This is maybe not the place to ask this, but have you ever tried reaching out to Google directly, maybe the gLinux team? Maybe it’s just that they haven’t realized it’s broken even though there are people interested in maintaining intergrations.

It seems that the bottleneck was a legacy dependency signon-ui / signond.

See the most recent comments on:

In macOS and windows, G-Drive gets paid via data-mining, and they can easily add telemetry services for mining data,

But in Linux, well…

Solution: Enforce website

It has remained unchanged for a long time, so it should be fine. This is most likely G-Drive’s issue/plan.

I’m afraid I’m not a cynic enough to just say “companies bad”. Google has a FOSS faction, regardless, which seems to be removed from the software maintanence cycle.

That is a problem and it can and should be solved.

And regarding signon-ui/signond, the thread suggests that the break is an oversight more than anything. As the earliest working version was committed some 5 years ago, I will give both Google and Debian maintainers the benefit of the doubt on this one. It’s neither a consious matter of Google harvesting more data, nor maintainers de-googling it.

Fixed as of Plasma 5.27.8 / KDE Neon 5.27 .

Still a bit finnicky, with follow-up pop-ups but at least the integration is fixed :slight_smile: