KRFB starting automatically and use

I have discovered KRFB which is superb as I can’t get standard VNC to work well on my OpenSUSE install.

However, two questions:

  1. I have added it to start automatically in system settings, but it launches itself in a window on boot. How can I have it not do that (i.e. start quietly)

  2. I can’t use it until the machine has been logged in at the console. This means if I need to reboot the machine it can’t be used until someone has physical access. Is there a way around that?

Otherwise it seems great and allows me to provide support to other users with ease.

n.b. - I am using X11 rather than Wayland if that makes any difference.

Hi,

1 Krfb start on boot with the pop up window, no idea how to avoid it, not a problem in my case.

2 To avoid the physical access on the shared machine with krfb you have to set your desktop environment under X11. Wayland is buggy with krfb, more details below

Edit : krfb is a nice vnc tool to share your desktop, don’t forget krdc to remote a device.

Thank you.

I have worked out (1) - add the parameter --nodialog to the command

But concerning (2) what exactly is it necessary to set?

1 thanks for the tip (I’m not a power user :-)

2 if you set your desktop with wayland you have to confirm manually the sharing desktop device at boot, if you set the shared device with x11 you don’t have to confirm the shared device.

krfb + wayland is buggy, if you enable unattended access you have to confirm a connection ! it is the bug… read the post on my previous post for more details