Multiple issues for novice user

I’ve facing some issues that seems related but, as I’m not an expert, I can’t confirm.
Here the list:

  1. Dolphin, randomly, is losing (again) the height of the panels. I’ve opened a bug and it was solved. Now, from some days, it started again to do this. The worst thing is that now sometimes it saves the height value and sometimes not. It seems that it fail to load some config file or settings (I don’t know if it has some config file, I think yes but I don’t know)

  2. SOLVED! This tip works! ---- The image file previews is not working when I open network folder. @meven said me this but I can’t judge if my shares are with smb// or network filesystem. My network folders are mapped using fstab like I’ve written here. Considering that some days (weeks) ago the previews are correctly working on the same folders.

  3. In the mapped network folders, it seems that there some permissions conflicts. The same as image file previews, until some days ago everything was fine. At the moment, for example, I can’t save a PureRef file as PureRef send me a message that sounds something like the PureRef can’t overwrite the file. I get the same message if I try to create a new PureRef file in that or other network folders.
    If you think now that it’s a PureRef problem, consider that I’ve tried to save the needed PureRef file on the desktop (everything was fine) and then I’ve tried to copy on the needed location. Dolphin failed to copy it…it stay blocked forever with the copy/move notifier window opened with no progress.

  4. System Monitor is crashing (using X11) like reported here. As I’d like to help devs on tracing the problem, I’d like to know how I should create a backtrace file to add to my bug report. I’ve followed the link posted on the bug default message but I can’t clearly understand what I should do considering that I’m on KDE Neon.

  5. The graphic pen settings doesn’t save the customization of the active area of the tablet if you add a profile over the default one.

I hope you’ll can help me solving these problems and I hope, in this way, to improve my knowledge to be able, in the future, to help by my self without opening threads for things that could be easy, for expert user, to solve (or avoid :slight_smile: ).

Thanks in advance.

What specific step are you struggling with?

If you can reproduce the crash you can start gdb from the terminal like so:

  1. gdb plasma-systemmonitor
  2. run
  3. Say yes when its asking you to enable debug symbols
    At this point Systemmonitor should open up. Reproduce the crash.
  4. In the terminal type bt
  5. Post the information
  6. You can quit gdb with quit
1 Like

Thank you very much. Your instructions seems more simple. :slight_smile:
This is what console write as soon as I click (with mouse) on a process in “Applications” section of System Monitor.

Thread 9 "QSGRenderThread" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffd2ffd640 (LWP 5386)]
0x00007ffff60614ee in QSortFilterProxyModel::sibling(int, int, QModelIndex const&) const () from /lib/x86_64-linux-gnu/
(gdb) bt
#0  0x00007ffff60614ee in QSortFilterProxyModel::sibling(int, int, QModelIndex const&) const () from /lib/x86_64-linux-gnu/
#1  0x00007fffdb10e1df in ?? () from /usr/lib/x86_64-linux-gnu/qt6/qml/org/kde/qqc2desktopstyle/private/
#2  0x00007fffebcbbb45 in QSGDefaultPainterNode::paint() () from /lib/x86_64-linux-gnu/
#3  0x00007fffebcbc048 in QSGDefaultPainterNode::update() () from /lib/x86_64-linux-gnu/
#4  0x00007fffebd2bc00 in QQuickPaintedItem::updatePaintNode(QSGNode*, QQuickItem::UpdatePaintNodeData*) () from /lib/x86_64-linux-gnu/
#5  0x00007fffebd99ac7 in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /lib/x86_64-linux-gnu/
#6  0x00007fffebd9a094 in QQuickWindowPrivate::updateDirtyNodes() () from /lib/x86_64-linux-gnu/
#7  0x00007fffebd8f99e in QQuickWindowPrivate::syncSceneGraph() () from /lib/x86_64-linux-gnu/
#8  0x00007fffebbbb865 in ?? () from /lib/x86_64-linux-gnu/
#9  0x00007ffff6183c9d in ?? () from /lib/x86_64-linux-gnu/
#10 0x00007ffff5694ac3 in start_thread (arg=<optimized out>) at ./nptl/pthread_create.c:442
#11 0x00007ffff5726850 in clone3 () at ../sysdeps/unix/sysv/linux/x86_64/clone3.S:81

Is it that kind of backtrace should I expect?
I’ll post in the bug I’ve opened…I hope it will help.

I’d like to share more about the issue n°3.
As I’m suspecting some permissions rights conflict, I’ve done some tests and here the results.
With Dolphin I can create a file (for example a text file), open it, modify with the right application, save it… so I can imagine that, I have the rights to read/write. Correct? But if I try to copy that file and make a duplicate, Dolphin freeze itself showing the copy progress window but it stay there forever.
I’ve made also a test with a console to make a copy and, without using “sudo”, I can copy the file. So, it seems that Dolphin has something that doesn’t work.
Any suggestions for any other tests to do to analize what’s going on?

Digging more on the issue n°3 it seems that sometime ago, some people had the same issue with the copy file with Dolphin within network drive.
Anyone that map successfully network drive with cifs can share his fstab setup?
I had try, with a virtual box, a fresh Neon installation and I have the same problem (with the same fstab setup)…so it seems that the problem but I can’t understand which one…as, until some days ago (some updates ago), it worked perfectly.

Please avoid these grab-all issue reporting.
Please open individual topics.

It is impossible to properly communicate this way, each answer about a point being noise for the the others and very soon everything becomes ten times harder to read and follow, which makes it more likely for anyone to loose interest, especially those that can help.

You are addressing to people doing things on their weekends and spare time…

Hmm, do you use a custom theme or plasma style? If yes can you try with the default breeze theme?

Sorry for this… it was completely unintentional.
I was thinking it was better to have just one point…

I know you (devs) are doing this in your free time so I haven’t any claim. Sorry again for this.

I understand, this is very convenient for users and intuitive.

Unfortunately as explained is not very practical for the community.
So we have to constantly educate the audience to avoid repeating ourselves over and over.

Btw, you already opened at least one bug and found one that matched an issue of yours which is great.

1 Like

Tonight I should be able to test it… I hope you’ll right.

I’ve test your suggestion but it doesn’t work…it still crashing.
Just to be more precise, before re-testing I had a the dark breeze with some customization (nothing particular, just minor things) but then I’ve choosen the default bright breeze theme and then I’ve re-test the system monitor but still crashing.