On error KDE6 X11 switched to the Software-Renderer - how to reverse?

I had the software renderer permanently kick in after some plasmashell errors under X11. A logout or reboot doesn’t reset it.

This seems similar to the “compositor” switch in KDE5 which could be reversed via the Systems Settings GUI.

Similar to KDE5 compositor warning dialog, I think there was a brief dialog flash up mentioning the software rendering was activated. But it lacked any OK button, so it just flashed up without me being able to fully read it.

I couldn’t find a switch to re-enable hardware rendering in KDE6, but by comparing with backups I eventually found I could edit ~/.config/kdeglobals and remove:

  • Is that all that needs changing?

  • Is there a GUI setting I’ve missed?

BTW, for me the software renderer cause the panel and tray to draw incorrectly, so it wasn’t usable (this would be with X11 on Tumbleweed 20240328 and Nvidia 550.54).

Actually the KDE5 compositor warning dialog was my own local code. I’d forgotten that I had a autostart script that did:

compositor_enabled=$(qdbus-qt5 org.kde.KWin /Compositor org.kde.kwin.Compositing.active)

if [ "$compositor_enabled" != "true" ]
     notify-send -a "Check Compositor" -t 0 -i dialog-error.png 'Hardware -> Display and Monitor -> Compositor is disabled!'

So ignore the bit about KDE5 warning, except to ask if it’s possible to do something similar to the above for the Software Renderer?