On-Going Glitches/Bugs with KMyMoney on MS Windows

It was suggested I post here. Two buggy behaviors noted:

  1. using master cl-msvc win, 3238 was last master I tried, I found any action related to scheduled transactions would cause app to suddenly crash. In the register/ledger, trying to enter next or edit caused the crash. Have not gone back to a master, since this makes program too difficult to use for my needs. This crash is not happening on the 5.1 - 3218 that I am now using and scheduled transactions function normally.

  2. the non-master 5.1-xxxx versions have been writing a debug.log to my win desktop with the following line: [0511/120533.095:WARNING:resource_bundle_qt.cpp(119)] locale_file_path.empty() for locale

From debug view - only thing that looks relevant are these 3 lines:

81 1.345508 21616 kmymoney.exe Qt WebEngine resources not found at C:/Program Files/KMyMoney/bin/resources. Trying parent directory…
82 1.345646 21616 kmymoney.exe Installed Qt WebEngine locales directory not found at location C:/Program Files/KMyMoney/bin/translations\qtwebengine_locales. Trying application directory…
83 1.345689 21616 kmymoney.exe Qt WebEngine locales directory not found at location C:/Program Files/KMyMoney/bin\qtwebengine_locales. Trying fallback directory… Translations MAY NOT not be correct.

Notes:

  1. Searching shows that under …/bin, there is no /translations, no /resources and no qtwebengine_locales. There is a /bin/data/locale.

  2. To the best of my recollection, the last “master” I tried did not write this debug.log to my desktop. But had the sch’d trx crashes.

  3. This only appears on my desktop pc - was win 10pro, now win 11pro, no difference. Does not appear on my win 10pro laptop - looks like same subfolder structure.

(Thanks for posting this here. It will likely get more eyeballs, just in case someone else can thing of anything new.)
I don’t think we have any current solution to the crashing with scheduled transactions in master, nor the unwanted log file in the 5.1 version.
Just to be sure - are you running the exact same versions on the desktop and laptop? Since both are now Win11pro, it may be hard to tease out the relevant difference, but there certainly is one, if only we can find it and then figure out how it contributes to the problem. If I remember from previous discussions about this, the cause is likely not in KMyMoney code directly, but in one of the underlying Qt or KDE libraries being called.

Desktop was win10 pro, now on win 11 pro as of a few days ago - kmm appears unchanged, was on a 3xxx then tried a master again, no debug on desktop, but crashing persisted so reverted back to 3218 - debug.log has been appearing for quite some time. Its better than the crashing.

Laptop is win 10 pro and has not changed due to age and only option is to force a win 11 upgrade which I am not up for at present. Anyway, kmm on laptop was a slightly older 3xxx version which I just updated to be same as desktop - 3218, and I can confirm no debug.log is appearing on desktop - I’ll chk temp locations next time I use it. I had been using laptop routinely for a couple of months during relocation and never got a debug.log on desktop.

I want to “waste” my resources on trouble-shooting the crash with the schedules rather than figuring out how that debug.log file is created.

I have 86 schedules here in my production environment and don’t see that problem (even if running on a Windows PC). I expect this to be happening due to a special something in your data which does not harm the 5.1 version but has this severe impact on master. BTW: Does it happen on all or only some of the schedules?

Can you please create an anonymized version of your file and check if the problem with editing/entering of schedules persists when you open the anonymized file? Please post the result here and I will think about how to proceed. TIA.

Agree log on desktop is a minor issue, just odd only happens on desktop machine. Does not happen with master releases. May try full uninstall, clean out reg, clean out left overs, then reinstall.

I have under 10 scheduled trx- two deposits and I think 4 routine pmts, i just tried the two dep’s that were ready to post 2 days prior to the scheduled date and one had changed so I tried to edit the date to post, app crashed. Tried to edit the splits/amts on the second, app crashed. retried both a few times with same crash so gave up and went back to 3218. Best I recall the crash was when I hit save or enter. Updated to the latest master, same crashes. Went back to 3218 and all scheduled trx work perfectly.

No crashes with 3218, so I’ll have to revert back to a master release to try an anonymized file - will try before I clean out for fresh install.

Just loaded current master to test scheduled transactions. None are set to auto-post in the ledger since all can change they are checked off as estimated. Opening the scheduled transactions tab on left and using them or editing them from the tab seems stable - none crashed and I could edit and enter next without issue.

The crash only happens when trying to use the scheduled transaction that displays with the yellow warning symbol in the ledger. In the config, I set scheduled trx to display in ledger 5 days in advance. Its these that cause the crash.

Note: trying to open the anon.xml causes app to crash, trying to create new book causes app to crash.