Personalized keyboard shortcuts gone after update to plasma 6. How to put them back?

Hello,

After updating to kde plasma 6.0 the keyboard custom shortcuts are gone.

I used to have a group and in that group all my shortcuts.

I’ve tried to click on the “import” top right option and selected “personal scheme” and remove the “filter” to be able to see all files and them select the backup file of my shortcuts.
It ended up with an entry in the “system preference” section.
But it still doesn’t work as it appears to only have the labels/text/title of my shortcuts and the keyboard shortcut to activate them, but no action assign to it.

Any way to import my old group of keyboard shortcuts?

1 Like

This happens to me too and I’ve posted on bugs kde org about it as well. How they didn’t consider this a critical issue is beyond me, and there’s no recommended solution.

I’ve “upgraded” to KDE Plasma 6.0.3 on Xorg

In Plasma 6, System Settings has no more a “Custom Shortcuts” section.

I have read that khotkeys (Plasma 5) was deprecated and would not be maintained in Plasma 6, months ago, when I was trying Plasma 6 alpha / beta / RC in KDE Neon Unstable.

So, I had to replace my Custom Shortcuts (commands) with the shortcut options that still exist.

This works in KDE 6.0.3

System Settings > Shortcuts > Add New > Command or Script ...

For those visual types like me

2 Likes

I couldn’t get it to work. I tried using the dialog box you show in the screenshot with simple bash scripts, direct commands like “echo hello”, but nothing happened.

I’m trying to replace khotkeys functionality (sending different key combinations with specific custom shortcuts) using xdotool. There’s a bunch of automations I set up using khotkeys that’s useless now that they removed it, and it’s a deal-breaker for me.

I’m not sure what I’m doing wrong and there’s no documentation on this part yet.

If you or someone else could provide an example of how to use this feature (especially using xdotool or an equivalent Wayland tool) it would be highly appreciated.

this kind of command worked for me

xdotool type ','

could you share a specific example of what you are trying to do ?

Yeah, shortly after our exchange I managed to get it to work with this sort of command. It seems to be very unreliable, though, which is why I didn’t think it was working. I press the shortcut defined but only one in three or four presses seem to register.

I’ll see whether this is fixed in Plasma 6.1 and then post a bug report.

Thank you for the help!

1 Like

oh now I see that if you press continuosly it doesn’t work every time.

I also use rust based text expander software Espanso for creating texts shortcuts. Have you check it already?

I generally use the shortcuts’ functionality to create alternative key bindings for various keyboard keys (e.g. using ctrl+key to navigate with the keyboard instead of the arrow keys).

Espanso seems really cool though - I will definitely give it a go!

It worked, here.

I have selected “Command or Scripts”, and pasted this:

gnome-screenshot -w -p -d 7 -f /run/media/flavio/Warehouse/0_PrtScn/$(date +%F_%H-%M-%S)_A.jpg

-w for active window
-p for include pointer
-d for delay (7 seconds)
-f for save in a JPG file to (path + filename pattern)

and set “CTRL+Print” shortcut.

Here is it:

and I have manually added “-CTRL-PrtScn-gnome-scrrenshot-Window-Delay” after “_A” – which I use for identify it is from Arch:

2024-05-31_21-54-57_A-CTRL-PrtScn-gnome-scrrenshot-Window-Delay.jpg

$ kinfo
Operating System: Arch Linux 
KDE Plasma Version: 6.0.5
KDE Frameworks Version: 6.2.0
Qt Version: 6.7.1
Kernel Version: 6.6.31-2-lts (64-bit)
Graphics Platform: X11
Processors: 6 × Intel® Core™ i5-9400 CPU @ 2.90GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630

$ systemsettings --version
systemsettings 6.0.5

$ echo $XDG_SESSION_TYPE
x11

gnome-screenshot will not work on Wayland session, I guess.