Plasma 6 I can't switch to X11

After updating to the latest plasma, I cannot log out, restart or shut down the system.
When switching user, I can select X11, but it hangs on a black screen with a cursor. Wait for fixes? The only solution is to turn off the computer using the button on the casing. On Wayland start system is slower than X11 ( on Plazma5)

1 Like

I have dealt with the same. Here is what I’ve done to get back to X11 with Reboot & Shutdown working again:

System SettingsColors & ThemesLogin Screen (SDDM): Click the “Behavior” button up top. Top checkbox you can go to the dropdown & select X11.

Power button fixes are below.

1 Like

Ok X11 back, but boot still slower than Plazma 5.27.10
Still reboot, shotdown and logout not work. Switch user same problem as wayland freez with coursor.


You talking about these files?

can you check what ls /usr/share/dbus-1/services/ | grep kde outputs?

Yeah, I was just coming back here to say the Power, Reboot, and Log Off don’t work, but Sleep & Switch User does. I’m still digging, I see Duha in this one & he fixed my KRunner one so I know where this is already going :slight_smile:

Possibly

org.kde.LogoutPrompt.service
org.kde.Shutdown.service

Is missing? Atleast I have this on my system.

Yeah, they are definitely gone for me. Go ahead and spit out a cat please :slight_smile:

[duha@archlinux ~]$ cat /usr/share/dbus-1/services/org.kde.Shutdown.service

[D-BUS Service]
Name=org.kde.Shutdown
Exec=/usr/bin/plasma-shutdown

[duha@archlinux ~]$ cat /usr/share/dbus-1/services/

org.kde.LogoutPrompt.service
[D-BUS Service]
Name=org.kde.LogoutPrompt
Exec=/usr/lib/ksmserver-logout-greeter
1 Like

I noticed you don’t have krunner in the list, you will need to create it if you use krunner. Duha answered my question if you go back to the main help topic on how to fix that.

Thanks for the question.

@nixternal thanks for the answer, same as plasma 5 :-)

1 Like

Those didn’t work. Still no Restart, Shutdown or Log Off working. I just realized there is no /usr/lib/ksmserver-logout-greeter on this machine :confused:

I see that ksmserver-logout-greeter should be in /usr/lib/x86_64-linux-gnu/libexec but it isn’t. More packaging bugs possibly.

Looks like it: here is the bug report: 481938 – Unable to leave session via Desktop menu on Plasma 6.0.0

4 Likes

This works, I can now reboot, shutdown & everything. Here is my /usr/share/dbus-1/services/org.kde.LogoutPrompt.service file:

[D-BUS Service]
Name=org.kde.LogoutPrompt
Exec=/usr/lib/x86_64-linux-gnu/libexec/ksmserver-logout-greeter
3 Likes

good job. Can you add that information to the bug report or would you like me to add it?

I’ll do it right now. Thanks!

1 Like

I don’t use Krunner and disable it. This is the reason?

No it’s not, that was an issue I had because I do use krunner.

I hope they fix the long start problem.

How did you done this. On my installations this did not work. No reaction if i click on logout, shutdown, reboot. Also not from SDDM Greeter.