Plasma 6 update, desktop won't load

Hello, Was wondering if someone could help. The plasma 6 update came on my system this morning. The login screen comes up fine, but the desktop won’t load. I get the my browser, which was set to load on startup, but nothing else. Black screens - I have 2 monitors - no panels, and no way to open programs.

Do you see any error in the systemd unit log of plasma-plasmashell ?

I see some kind of error flash right before the login screen, but can’t read it. How would I access the log?

try sudo journalctl -b -1 -p3

I just upgraded on Neon. Getting a similar thing. I see the login splash screen. I enter my password, the screen goes dark, then I get returned to the login screen.

I used PUTTY to look around. The kernel is running normally ( generic).

I tried a login and got this from /var/log/syslog

jim@linux:/var/log$ tail /var/log/syslog

Feb 28 09:40:07 linux dbus-daemon[1521]: [session uid=118 pid=1521] Activating via systemd: service name=‘org.freedesktop.impl.portal.desktop.gtk’ unit=‘xdg-desktop-portal-gtk.service’ requested by ‘:1.10’ (uid=118 pid=2516 comm="/usr/libexec/xdg-desktop-portal " label=“unconfined”)

Feb 28 09:40:07 linux systemd[1506]: Starting Portal service (GTK/GNOME implementation)…

Feb 28 09:40:07 linux xdg-desktop-por[2521]: cannot open display:

Feb 28 09:40:07 linux systemd[1506]: xdg-desktop-portal-gtk.service: Main process exited, code=exited, status=1/FAILURE

Feb 28 09:40:07 linux systemd[1506]: xdg-desktop-portal-gtk.service: Failed with result ‘exit-code’.

Feb 28 09:40:07 linux systemd[1506]: Failed to start Portal service (GTK/GNOME implementation).

Feb 28 09:40:07 linux sddm-greeter-qt6[2510]: Adding view for “VGA-0” QRect(0,0 1920x1200)

Feb 28 09:40:07 linux sddm-greeter-qt6[2510]: Hunspell dictionary is missing for “en_CA”. Search paths QList(“/usr/share/qt6/qtvirtualkeyboard/hunspell”, “/usr/share/hunspell”, “/usr/share/myspell/dicts”)

Feb 28 09:40:07 linux sddm-greeter-qt6[2510]: Message received from daemon: Capabilities

Feb 28 09:40:07 linux sddm-greeter-qt6[2510]: Message received from daemon: HostName


I get a dependency error (in apt) afer update using discover, about:
neon-desktop → plasma-desktop-data

I can’t get to terminal. It just makes a sound if I use alt-space, or alt-F2, but won’t give my someplace to write anything. I can run neon from a usb drive to access files, could I find them that way?

You still have tty (CTRL+ALT + F3 for instance) or recovery-mode.

Which is your distro ?

Okay, ctl alt f3 works, sorry didn’t know about that. My distro is neon. I ran the journal command, Is there any easy way to share it with people, from the terminal, or am I looking for something in particular. Sorry to be fairly new to all this.

You can try to run startplasma-wayland 2>&1 | tee output.log, it will store the output of startplasma-wayland in to the file output.log.

Then it seems you have a second computer you can use ssh from the second machine to connect to the one with the issue, ssh <my-other-hostname> and use cat or scp to grab the output file.
This might be too technical for you.

I tried the startplasma-wayland 2>&1 | tee output.log Not much returned…

jim@linux:~$ more output.log

Error: could not determine $DISPLAY.

Error: Can not contact kdeinit5!

org.kde.startup: “kdeinit5_shutdown” QList() exited with code 255

startplasma-wayland: Shutting down…

startplasmacompositor: Shutting down…

startplasmacompositor: Done.


Well I couldn’t get the ssh to work, so I just took a picture with my phone. Hopefully you can read it.

I’m running KDE Neon User Edition. Similar to a comment above, I ended up with a blank screen after rebooting from the latest Discover update, which contained various updates to Plasma 6.0.0. So, I did a Ctrl-Alt-F2, logged in at the command line and typed:

sudo pkcon update

and it terminated with the following:

Fatal error: The following packages have unmet dependencies:
plasma-desktop: Depends: plasma-desktop-data (= 4:5.27.10-0xneon-22.04+jammy+release+build47)

My current plan is to wait a while and see if the repo was still being updated when I took the update. But if there’s an actual problem, I hope this helps.

1 Like

Yeah I get the same fatal error if I try to update

Just tried sudo pkcon update…

Getting updates
No packages require updating to newer versions.

I just had the same problem with my neon.

I had to do an :

sudo apt autoremove
sudo pkcon install libdecor-0-0
sudo pkcon install libsdl2-2.0-0
sudo pkcon install plasma-desktop
sudo pkcon install plasma-desktop-data

(before that I removed VLC but dit not remember if it was with apt or pkcon )


That fixed my problem. Thanks Herve!

That fixed my problem as well. Thanks much Herve!

Well, it mostly fixed things. Now the desktop works, but Krunner won’t open. It gives me a “Launching Krunner” failed error. The name org.kde.krunner was not provided by any .service files.