Plasma starts with black screen


So I have been using KDE Plasma + SDDM on FreeBSD 13.1, 13.2 for some time, mostly problem free. But every once in a while, when logging in with SDDM, plasma does not start correctly. I get a black screen, but I can see my mouse cursor. I can CTRL+ALT+T to open a terminal, but for example the task bar and the wallpapers do not load. Sometimes I get a file plasmashell.core in $HOME, this time I got a file drkonqi.core in $HOME. Usually, what I can do, is hit CTRL+ALT+DEL, then Plasma shows me the session options (logout, shutdown, restart, etc.). I can then log out, log back in again and after this procedure Plasma loads fine.

To install KDE Plasma I followed the instructions on FreeBSD/Setup - KDE Community Wiki. I installed xorg-minimal and plasma5-plasma using the default LATEST binary packages. I am using a GTX 1080 Ti with the latest nvidia driver. I set Indexing-Enabled=false in $HOME/.config/baloofilerc because baloo would sometimes also produce dumps with a size of 256 Gigabyte.

Please let me know if more information is needed.

Any help for diagnosing would be greatly appreciated.

1 Like

does this ever happen when loading linux from a fresh restart or is it limited to resuming your session from suspend?

if its the latter, then it could be that your desktop graphics are not being saved to disk when you suspend and then when you resume there is nothing to load so you get squat.

you can start here, but the rabbit hole for nvidia cards goes DEEP.

Up until this point I haven’t bothered with configuring / testing suspend or standby or anything similar so I wouldn’t know. Most often I get this problem on the first plasma login after cold boot and reboot. Previously I sometimes got a black screen back to back when logging out and logging back in but that usually fixes it. When I say previously I mean before I did a complete wipe and fresh install, about 2 weeks ago. I thought that solved it but actually it keeps happening again.

I will have a look at the link you provided, it might contain some hints for me, thanks.

Maybe you or somebody else can point me in the direction of any logs that need checking or any tests I can do (I cannot reproduce this reliably)? At least I don’t see any errors in the system log (/var/log/messages). I’m not yet very familiar with Plasma so I wouldn’t know where to look.

(BTW, FreeBSD is not a Linux distro but IMO that shouldn’t make a big difference). I have read some threads of other users having this problem on Arch for example but that never lead to a solution for me…

Hi FellowBSD user :slight_smile:

occasional black screens while plasma starting sound like a race condition.

I had similar starting black screens, when my wifi wasn’t up, yet, and the plasma session trying to get restore/access network data I previously accessed on a NAS.

I got rid by disabling the recently accessed files and session management altogether.


Hi :smiley:

It’s interesting you bring this up because on my previous install I had a feeling it might have something to do with this. I do mount NFS shares using autofs which may very well be the culprit. Maybe I can change something concerning autofs behaviour. I am using a pretty fast wired connection so for the moment I don’t suspect this to be the cause.

This is within the Plasma system settings GUI app, right?
Edit: I found the setting regarding recently accessed files but I don’t understand what exactly you mean by session management. Did you set “Start with an empty session” in the “Startup and Shutdown > Desktop Session” section?

Here’s the recently accessed files for the activity:

This is how session management looks like for me :

here’s how my mount opt in the nas autofs entry look like
nas_drive -intr,nfsv3,rw,noatime,nosuid,exec,soft,retrycnt=1, <IP_of_NAS>:/

Haven’t had a black screen anymore then, but don’t know which did the trick exactly. Probl. all together :slight_smile:

Great, thanks! :+1:

I’ll set these options and see if I get any improvement (like I said it can be hard to tell because that black screen on login happens very irregularly). My NFS mount options are quite similar.
There is also a sysctl tunable in man autofs - - vfs.autofs.timeout: Number of seconds to wait for automountd(8) to handle the mount request. Defaults to 30.

Changing this could possibly help too.

In any case I will make sure to report at a later date to confirm if this in fact solved the issue. :grinning:

1 Like

It has been almost two weeks and so far I haven’t gotten the black screen on login anymore. Setting the Plasma options suggested by Tionisla solved the problem. I didn’t change any autofs, NFS or sysctl options.


Glad, I was of any help :slight_smile:

#FreeBSD #runBSD