Shutdown Button not working after switching to KDE 6 on KDE Neon

After KDE neon updated automatically from KDE 5.27 to 6.0 the shutdown button is not working anymore (I can press it but nothing happens), so I have to use the terminal to shut down (which is working, so it is proparly not a hardware problem, but a KDE Problem or Bug).

The other buttons like Sleep are working, only the shutdown button is not working.

Is this a known Bug?

You can look a little first at least before asking.

A workaround is at 481938 – Unable to leave session via Desktop menu on Plasma 6.0.0


The same occour to me.
I suppose that in next days will be a update to solve the matter

Can confirm on KDE Neon.

Same for me. X11.
Operating System: KDE neon 6.0
KDE Plasma Version: 6.0.0
KDE Frameworks Version: 6.0.0
Qt Version: 6.6.2
Kernel Version: 6.5.0-21-generic (64-bit)
Graphics Platform: X11
Processors: 6 × Intel® Core™ i5-8500 CPU @ 3.00GHz
Memory: 15.4 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630
Manufacturer: HP
Product Name: HP EliteDesk 800 G4 SFF

Only thing you can do right now is just run the commands:

reboot (to reboot)

shutdown now (to shutdown)

systemctl restart sddm (to bring back to login screen)

You can make a shortcut in the app launcher. “systemctl” as the executable, and then “restart sddm” as the argument. When you click that shortcut, you’ll be prompted for your password.

This is a sly way of killing the session.

poweroff also works for shutting down.

1 Like

Which command is recommended for logging out? I tried something which just caused the system to hang. Had to use the power button.

Same issue for me. Have to use “sudo reboot” and “sudo shutdown”.
This happens after any system update.

The system is AMD Ryzen 2700X with 2x RX 580 GPUs.

No need for sudo.

Also, with this issue, I find Krunner very useful (once you get that working). Then just hit alt+f2 and type in “reboot” or “shutdown now”

A lesson to be sure; avoid upgrading to a totally new version of the desktop when it’s just released. I also made the same mistake this time around.

1 Like

systemctl restart sddm (to bring back to login screen by restarting the display manager)

You can make a shortcut in the app launcher. “systemctl” as the executable, and then “restart sddm” as the argument. When you click that shortcut, you’ll be prompted for your password.

This is a sly way of killing the session.

I’ll add it to the list.

1 Like

It should be fixed now with a new Neon snapshot.

But I’m really sorry this happened. The roll-out of Neon’s packaging of Plasma 6 was unacceptable, and we’ll be conducting an investigation to determine how it happened and make sure it doesn’t recur.


Updating KDE neon to the latest version immediately fixed the issue for me, including multiple others, great!

Yes, it fixed the issue, but I tested it just now by hitting Restart, which gave me a prompt as expected. Then I hit Cancel. Immediately the system froze, KDE crashed, and then KDE restarted itself.

Also, I can consistently cause a crash of the same kind when I have a Firefox window open and then try to open Discoverer.

I am using Wayland.

Moz crash reason: “Error 32 (Broken pipe) dispatching to Wayland display.”

That sounds like a different issue. I’d recommend reporting a bug using Make sure to include a backtrace of the crash!

I have never done a backtrace of a crash, and I don’t know how to do that.

Should KDE Neon have reporting like Mozilla Firefox has? When Firefox crashes, I get a prompt to send the data automatically to Mozilla. I can also go into about:crashes in Firefox to see past crash data I’ve sent, and to send any unsent reports. Wouldn’t this dramatically improve bug reporting for KDE? Most general users probably can’t be bothered with bug reporting because it is not automatic like this.

If I could opt in to send crash data like this, I would. Over the last 24 hours I have sent Mozilla at least 12 crash reports, but zero to KDE. That’s because Mozilla has the process easily automated. If my user behavior is like this, how many others are the same?

Also noticed Microsoft Edge has automatic bug reporting you can’t turn off. They state in the Privacy settings:

Required diagnostic data
“Microsoft collects required diagnostic data to keep Microsoft Edge secure, up to date, and performing as expected.”

If I could turn on in KDE something similar, I would. That feature allows Microsoft Edge to much faster improve stability and security than if Microsoft were not collecting that data. It’s a good feature and it doesn’t turn me off from using Microsoft Edge.

To debug the plasmashell process, this is what I usually do.

  1. Open console
  2. Run gdb plasmashell
    2b. If there is a prompt to use debuginfod, say yes
  3. At the gdb prompt type run --replace
  4. When the process crashes type bt full
  5. Press c to continue the backtrace
  6. Exit gdb at the next prompt with ctrl+d
    6b. If the plasmashell process doesn’t restart after exiting gdb, run plasmashell --replace from the prompt.
  7. Paste the backtrace into a file
  8. Open the kde bugtracker
  9. Create a new bug
  10. Add the file as an attachment

You can do this process with other applications too, such as non kde applications, up to step 7.


Fixed now. very thanks.

Did upgraded my Arch few days back and I have got myself into the same problem… Shutdown button does nothing. poweroff from terminal works…
Tried marked solution by running /usr/bin/plasma-shutdown even with sudo but the program just does nothing… no errors in journal, no standard output, nothing…

Can you help diagnose the problem? At least, where are the places I can look to check for any errors…