(Solved) Neon won't boot to Plasma after Kernel upgrade (6.5.0-14-generic)

I’ve been running Neon for years with no real problems. A few days ago I got an alert that there was a kernel upgrade to 6.5.0-14-generic, so I installed it.

Well… After installing it, I can’t boot to Plasma. I can CTRL-ALT-F to other terminals where I can log in. But if I try startX, it fails, so I’m limited to text terminal only.

If I go into grub at boot and select an older kernel, (6.2.0-39-generic) everything runs fine.

Normally I can manage bugs here and there, but this time I’m stumped. How can I get Plasma running under the latest kernel ?

Below is the info on my system and the text from Xorg.0.log showing the failure.

From kinfo…

KDE Plasma 5.27.10
KDE Frameworks Version 5.113.0
QT Version 5.15.11
Kernel Version 6.2.0-39-generic (64 bit)
Graphics Platform X11

Processors 8 x intel Core i7-6700K CPU @ 4.00GHz
Memory 31.3 GiB of RAM
Graphics Platform GeForce GT 730/PCIe/SSE2

Contents of Xorg.0.log after a failed attempt to run X

[ 53.265]
Xorg X Server
X Protocol Version 11, Revision 0
[ 53.270] Current Operating System: Linux linux 6.5.0-14-generic #14~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Mon Nov 20 18:15:30 UTC 2 x86_64
[ 53.271] Kernel command line: BOOT_IMAGE=/vmlinuz-6.5.0-14-generic root=UUID=a76c829d-5f8c-4ee8-ad9a-0ff89278f431 ro quiet splash vt.handoff=7
[ 53.275] xorg-server 2:21.1.4-2ubuntu1.7~22.04.5
[ 53.276] Current version of pixman: 0.40.0
[ 53.278] Before reporting problems, check wiki
to make sure that you have the latest version.
[ 53.278] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 53.325] (==) Log file: “/var/log/Xorg.0.log”, Time: Thu Jan 11 12:41:44 2024
[ 53.336] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[ 53.337] (==) No Layout section. Using the first Screen section.
[ 53.337] (==) No screen section available. Using defaults.
[ 53.337] (
) |–>Screen “Default Screen Section” (0)
[ 53.337] (**) | |–>Monitor “”
[ 53.338] (==) No monitor specified for screen “Default Screen Section”.
Using a default monitor configuration.
[ 53.338] (==) Automatically adding devices
[ 53.338] (==) Automatically enabling devices
[ 53.338] (==) Automatically adding GPU devices
[ 53.338] (==) Automatically binding GPU devices
[ 53.338] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 53.339] (WW) The directory “/usr/share/fonts/X11/cyrillic” does not exist.
[ 53.339] Entry deleted from font path.
[ 53.339] (WW) The directory “/usr/share/fonts/X11/100dpi/” does not exist.
[ 53.339] Entry deleted from font path.
[ 53.339] (WW) The directory “/usr/share/fonts/X11/75dpi/” does not exist.
[ 53.339] Entry deleted from font path.
[ 53.339] (WW) The directory “/usr/share/fonts/X11/100dpi” does not exist.
[ 53.339] Entry deleted from font path.
[ 53.339] (WW) The directory “/usr/share/fonts/X11/75dpi” does not exist.
[ 53.339] Entry deleted from font path.
[ 53.339] (==) FontPath set to:
[ 53.339] (==) ModulePath set to “/usr/lib/xorg/modules”
[ 53.339] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 53.339] (II) Loader magic: 0x55c3286b9020
[ 53.339] (II) Module ABI versions:
[ 53.339] Xorg ANSI C Emulation: 0.4
[ 53.339] Xorg Video Driver: 25.2
[ 53.339] Xorg XInput driver : 24.4
[ 53.339] Xorg Server Extension : 10.0
[ 53.340] (++) using VT number 2

[ 53.341] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[ 53.345] (–) PCI:*(1@0:0:0) 10de:1287:1462:8a9f rev 161, Mem @ 0xde000000/16777216, 0xd0000000/134217728, 0xd8000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x???/131072
[ 53.345] (II) LoadModule: “glx”
[ 53.345] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 53.348] (II) Module glx: vendor=“Xorg Foundation”
[ 53.348] compiled for, module version = 1.0.0
[ 53.348] ABI class: Xorg Server Extension, version 10.0
[ 53.933] (==) Matched nouveau as autoconfigured driver 0
[ 53.933] (==) Matched modesetting as autoconfigured driver 1
[ 53.933] (==) Matched fbdev as autoconfigured driver 2
[ 53.933] (==) Matched vesa as autoconfigured driver 3
[ 53.933] (==) Assigned the driver to the xf86ConfigLayout
[ 53.933] (II) LoadModule: “nouveau”
[ 53.934] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[ 53.937] (II) Module nouveau: vendor=“Xorg Foundation”
[ 53.937] compiled for, module version = 1.0.17
[ 53.937] Module class: Xorg Video Driver
[ 53.937] ABI class: Xorg Video Driver, version 25.2
[ 53.937] (II) LoadModule: “modesetting”
[ 53.937] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 53.938] (II) Module modesetting: vendor=“Xorg Foundation”
[ 53.938] compiled for, module version = 1.21.1
[ 53.938] Module class: Xorg Video Driver
[ 53.938] ABI class: Xorg Video Driver, version 25.2
[ 53.938] (II) LoadModule: “fbdev”
[ 53.939] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 53.939] (II) Module fbdev: vendor=“Xorg Foundation”
[ 53.940] compiled for, module version = 0.5.0
[ 53.940] Module class: Xorg Video Driver
[ 53.940] ABI class: Xorg Video Driver, version 25.2
[ 53.940] (II) LoadModule: “vesa”
[ 53.940] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 53.941] (II) Module vesa: vendor=“Xorg Foundation”
[ 53.941] compiled for, module version = 2.5.0
[ 53.941] Module class: Xorg Video Driver
[ 53.941] ABI class: Xorg Video Driver, version 25.2
[ 53.941] (II) NOUVEAU driver Date: Sat Jan 23 12:24:42 2021 -0500
[ 53.941] (II) NOUVEAU driver for NVIDIA chipset families :
[ 53.941] RIVA TNT (NV04)
[ 53.941] RIVA TNT2 (NV05)
[ 53.941] GeForce 256 (NV10)
[ 53.941] GeForce 2 (NV11, NV15)
[ 53.942] GeForce 4MX (NV17, NV18)
[ 53.942] GeForce 3 (NV20)
[ 53.942] GeForce 4Ti (NV25, NV28)
[ 53.942] GeForce FX (NV3x)
[ 53.942] GeForce 6 (NV4x)
[ 53.942] GeForce 7 (G7x)
[ 53.942] GeForce 8 (G8x)
[ 53.943] GeForce 9 (G9x)
[ 53.943] GeForce GTX 2xx/3xx (GT2xx)
[ 53.943] GeForce GTX 4xx/5xx (GFxxx)
[ 53.943] GeForce GTX 6xx/7xx (GKxxx)
[ 53.943] GeForce GTX 9xx (GMxxx)
[ 53.943] GeForce GTX 10xx (GPxxx)
[ 53.943] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 53.943] (II) FBDEV: driver for framebuffer: fbdev
[ 53.943] (II) VESA: driver for VESA chipsets: vesa
[ 54.546] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
[ 54.546] (EE) open /dev/dri/card0: No such file or directory
[ 54.546] (WW) Falling back to old probe method for modesetting
[ 54.546] (EE) open /dev/dri/card0: No such file or directory
[ 54.546] (II) Loading sub module “fbdevhw”
[ 54.546] (II) LoadModule: “fbdevhw”
[ 54.547] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 54.547] (II) Module fbdevhw: vendor=“Xorg Foundation”
[ 54.547] compiled for, module version = 0.0.2
[ 54.547] ABI class: Xorg Video Driver, version 25.2
[ 54.548] (EE) Unable to find a valid framebuffer device
[ 54.548] (WW) Falling back to old probe method for fbdev
[ 54.548] (II) Loading sub module “fbdevhw”
[ 54.548] (II) LoadModule: “fbdevhw”
[ 54.548] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 54.548] (II) Module fbdevhw: vendor=“Xorg Foundation”
[ 54.548] compiled for, module version = 0.0.2
[ 54.548] ABI class: Xorg Video Driver, version 25.2
[ 54.549] (II) FBDEV(2): using default device
[ 54.549] (EE) Screen 0 deleted because of no matching config section.
[ 54.549] (II) UnloadModule: “modesetting”
[ 54.549] (EE) Screen 0 deleted because of no matching config section.
[ 54.549] (II) UnloadModule: “fbdev”
[ 54.549] (II) UnloadSubModule: “fbdevhw”
[ 54.549] (EE)
Fatal server error:
[ 54.549] (EE) Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices
[ 54.549] (EE)
[ 54.549] (EE)
Please consult the The Xorg Foundation support
for help.
[ 54.549] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 54.549] (EE)
[ 54.589] (EE) Server terminated with error (1). Closing log file.

This seems to be an issue with the 6.5 kernel. I don’ think you can do something about this, just wait until it is fixed. I think this is not only a neon issue as I think I also saw someone on Kubuntu saying the kernel upgrade broke.

Also as you seem quite knowledgeable could you please advice this user how to revert to an older Kernel? Boot broken after Discover update

working ok here

Operating System: Kubuntu 22.04
KDE Plasma Version: 5.27.10
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.3
Kernel Version: 6.5.0-14-generic (64-bit)
Graphics Platform: X11

but i have backports and backports extra turned on, so i don’t know if that impacts.

and i’m not running wayland.

Good to know @skyfishgoo maybe I was wrong about the Kubuntu thing, or its a nvidia thing.

something similar happened to me back when i first installed but it was to do with my /boot partition filling up with a bunch of useless (to me) kernel images (hwe, oem, etc)

that doesn’t seem to be the case here.

i would boot to advanced and run the dpkg and cleanup utilities to back out the kernel upgrade and just wait for a time.

Easy enough to do.

root@9600k:~# apt -s remove linux-image-6.5.0-14-generic
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages were automatically installed and are no longer required:
  amd64-microcode intel-microcode iucode-tool linux-headers-6.5.0-14-generic
  linux-headers-generic-hwe-22.04 linux-hwe-6.5-headers-6.5.0-14
  linux-modules-6.5.0-14-generic linux-modules-extra-6.5.0-14-generic thermald
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  linux-generic-hwe-22.04 linux-image-6.5.0-14-generic
0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
Remv linux-generic-hwe-22.04 []
Remv linux-image-generic-hwe-22.04 []
Remv linux-image-6.5.0-14-generic [6.5.0-14.14~22.04.1]

That will get the new kernel removed, do not do the autoremove it mentions as you want the microcode packages installed to get those used in the initrd when built to have those protections enabled. Same with the iucode-tool and thermald packages. If necessary use the apt-mark manual package-name to set it to manually installed to keep them, then it is safe to use the autoremove to get rid excess kernel junk. Or you can add those packages to the one I show in the first command to get them at the same time, removing the -s in the command gets them removed and does not simulate what will be done.

To the OP: What driver do you use for the nvidia card the log shows the noveaux being loaded for it. If you use the proprietary driver from nvidia it is supposed to rebuilt on every kernel upgrade/update to have a new module to load with the change kernel. No clue on the procedure now as it has been a good decade at least since I used an nVidia card in linux system, but you may want to check into doing it.

I would add I have no clue either on the 6.5.0-14 kernel usage as I got tired of watching my Debian installs have their kernel upgraded five times in the last month for security issues with nothing in sight from the ubuntu people. Of course that is until I install the zabbly+ kernel built for the 22.04 a few days ago. Then they come out with the new kernel of that kernel which got installed, since that stable version of the kernel works flawlessly on my machine I have not even booted into the 6.5.0-14 as the 6.6.11 shows up first in the grub list when it was updated to that last night and I rebooted into it.

Here on 3 Device the same after Update, but not Neon, Kubuntu, and One Ubuntu. Both have Nvidiacards build in. An i see that the nvidia kernel modul was not availlable. The drivers were too old, as were the built-in cards. These are no longer compatible with the new kernel. I downgraded to the LTS kernels, reinstalled the nvidia driver and it is working again.

On newer Hardware and new cards there was no problem.

It has append to me with a GF108 (i.e. GeForce GT 630). @mariol can you please share how did you managed to downgrade to LTS kernels and reinstalled the nvidia driver?
I am stucked right now :frowning:

I’m using ubuntu 22

My secondary monitors work normally, but the laptop screen only displays boot messages. Right after the kernel upgrade it still worked, albeit only at native resolution (i.e. tiny fonts), and trying to lower resolution would result in flickering white noise. Today, neither Plasma nor Nvidia utility even acknowledge the monitor exists. I guess it’s the same root problem, but I don’t know if it’s the same symptom. I don’t see any text anywhere that clearly says “error”. :thinking:

Log in to a TTY

systemctl stop sddm
apt install linux-generic
apt remove "*6.2.0-*" "*6.5.0-*" "*nvidia*" --purge
ubuntu-drivers install

I would add the new kernel works the same as any other I have installed. Today was the day for me to clone my install with my script I have to my spare identical back machine. I took the opportunity to boot into the ubuntu kernel and it worked fine, using the builtin Intel graphics.

Well THANKS for the reply!

When I tried the ‘apt install linux’, I got a message telling me that I had the latest kernel.

However, the ‘ubuntu-drivers install’ command did the trick. It was a major operation… Took a while with a lot of text rolling by and and I noticed that it installed a lot of nvidia stuff.

Now I can boot to X using the latest Kernel. Thanks again,

I downgraded the kernel to 6.2.0-39-generic, reinstalled ubuntu desktop, apt update upgrade from a live after mounting the volume.
I also performed some memory test (even if everything seems to work) and fscheck.

I also run the recovery mode and after that it has finally worked.

Same problem.

Operating System: Kubuntu 22.04
KDE Plasma Version: 5.24.7
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Kernel Version: 6.5.0-14-generic (64-bit)
Graphics Platform: X11
Graphics Processor: NVD9

The proprietary driver (nvidia-driver-390) of my NVidia card is not supported by this new kernel (6.5.0-14-generic). I spent a lot of time before finding this solution :

Using GRUB, launch : 6.5.0-14-generic (recovery mode).

Terminal :

sudo apt autoremove nvidia* --purge

Reboot and bingo. Now my system use Nouveau display driver.

Next step : buying an AMD Graphic card once and for all…

1 Like

Another is to use the kernel it shipped with I think it was the 5.1.15 that is LTS kernel supported until the year 2027 just like the Kubuntu you run. With such old hardware in the machine already it is very doubtful you need any of the drivers provided in the newer kernels.

Though ditching nVidia and their pathetic support of open source has its merits too. The builtin AMD driver has had some good support by them and works well.

To tell you the truth I’m tired of all these bad surprises I had with this graphic card vs Linux (used it with Mint, Manjaro, KDE Neon and now Kubuntu). I just ordered an AMD Radeon PULSE RX 580. NVidia our marriage is over. C’est la goutte qui a fait déborder le vase.


Thank for the support guys.
For everyone speaking Italian I have wrote what I have experienced in my blog.

A nice write up of what you did and one of the first chances I had to use Firefox’s new translation feature. It worked great the posting was very well translated.

1 Like


Have the same problem with KDE Neon - user edition - 20240201-07:44 - KDE Neon 5.27 : no other OS installed.

Before the update : everything was OK and running well !

Installed on my older laptop ASUS K70IC with Nvidia GEFORCE GT 220M - CUDA - 1GB.

What I have to do to solve this : please in detail : I’m a beginner !

Thanks in advance for your reply.
Best regards.

If you look up at the replies you’ll see the one from mariol.

I didn’t do the first few lines… All I did was issue the command:

sudo ubuntu-drivers install

After rebooting, X came back… Hope this works for you.