Upgrading from KMyMoney 4.8.0 to 5.1.3

Hi, I have been using KMyMoney Version 4.8.0 and KDE Development Platform 4.12.5 for years and only just seen that you have a new version 5.1.3. So downloaded the Win 64 version and installed it. It does not seem to like my existing data files however. I get an error saying it doesn’t have the right plugin. Please can you direct me to the missing plugin, or give me some other solution.

I hoped the export/import options would help, but its 1 export per account - and I must have 60 !! lots are closed down, but obviously have transfer transactions between them and to my remaining open accounts… I’d think it a miracle if I did all those individual exports and they tallied up accurately… Is export/import the only option ?

Many Thanks, Nick

Have you checked the plugin configuration dialog yet? Open Settings/Configure KMyMoney/Plugins and search for the XML Storage plugin. Make sure it is enabled.

Hi, thanks for the reply. All the plugins are enabled (ticked).
So is import/export the only option ? Why can’t we simply open the old file and get the app to convert to new format if necessary ?
I was puzzled as to why the install created a completely new folder structure and called itself KMyMoney5. As a software config / release manager in a previous life pre-retirement that type of naming was a real no-go !
best regards

There were so many things that changed from KDE4 to KDE5 and I honestly cannot remember all the details. Backward compatibility was one of our goals back then and it always worked, but somehow it does not get along with your data file (There was also version 5.0 in between)

Can you try to start the application from the command line and see if there is any message as to why it does not like the file?

If that does not provide a clue: the .kmy file is a compressed XML file (compressed using gzip). Can you try to un-compress the file and see if you can open it in an editor? As a former config/release manager I assume you have seen many ASCII files :slight_smile: BTW: no need to compress the file again: KMyMoney can read the uncompressed versions also and compress it when saving. But we’re not there yet.

Thanks Thomas,

uncompressing the old file has worked fine.

The main reason I went for the update was finding a support response to someone asking about the automatic investment price updates. These haven’t been working for me for ages (years!), but I thought I’d see if there was a solution. However the update has had no effect on this issue. Do you have any up to date advice ?

best regards


The online investment price update is a moving target also discussed in another thread and has a long history (on the old KMyMoney forum). Maybe, you find some hints on those pages.

Do I get it right, that your initial problem of not being able to load your data has been resolved and you are back in business?

Yes, Thomas, the conversion to xml worked fine. Thanks for that.
I’d seen that investment price update thread. That’s what led me to the 5.1.3 update- I didn’t realise any updates were planned, the development seemed to have stalled ages ago.
I’m going to do some more investigation around that this weekend, but the suggestions I’d seen didn’t work.
Best regards