Using Plasma I'm getting a blank screen with flashing cursor instead of login

I have a Lenovo laptop with an nVidia GeForce GTX 1660 Ti. I’m using MX Linux and after a update the system would boot normally, a splash screen would flash, I’d briefly see three large dots . . . on a black screen then I’d get an empty terminal screen with a flashing cursor instead of the login screen. The only key press that the system responds to is ctrl-alt-delete, which flashes a few lines of text then reboots the system. I can make a temporary edit to the GRUB entry and add “single” to the “linux” line to (I assume) enter recovery mode. When I do that I can either enter the root password to get to a command line or hit ctrl-d to get to a desktop. I disabled all startup programs by renaming the directory /home/[myuserneme]/.config/autostart" to “autostart-old”. The /etc/environment file is empty. I didn’t see any error messages in /var/log/Xorg.0.log. I saw no obvious error messages when I entered “journalctl -xb” at the command line prompt. I tried adding another account (“Test”) but that had no effect. I posted the issue to the MX Linux help board and had 126 views with only one useful reply (check Xorg.0.log). In theme settings I tried resetting to the default login screen then I tried switching to a different login screen but neither could get to the desktop. I think that’s everything.

Is there anyone who can help?

Are you trying to login to the X11 session or the wayland session?

Which nvidia-driver version are you on by the way?

Thank you, very much for replying. I don’t know how I’d be able to find out if all i get is an unresponsive, black screen with a flashing cursor but in recovery mode:



Wed Feb 28 11:12:35 2024
| Nvidie-smi 525.125.06  Driver Version: 525.125.06. CUDA Version: 12.0.   | 

Hello @fanzhuyifan , I am facing a similar issue. I just upgraded to plasma 6. I am facing an issue with the lock screen breaking.

Issue 1: When I start the laptop, everything loads normally, and I am greeted with Breeze default login screen. I am able to login normally and use my KDE neon. But! the issue happens when I lock :my screen. The moment I lock my screen and I try to log back in, my screen suddenly starts flickering and I am able to see the lockscreen for a second and then it keeps blanking out.
I am however able to see the mouse cursor. If I try to login to the desktop env during the flickering, I am able to, but since the screen is blinking, I am not able to see much or do much.

Issue 2: ctrl+alt+del is not working. I am trying to get the login, logout and shutdown promt, but it’s not loading. I even tried to click the menu button to sign out, that too isn’t working.

Steps I tried:

  1. Tried to reboot few times after the update by clearing the old files using sudo apt autoremove (it removed 450MB worth of data after the update)
  2. During the flickering at lock screen, I type my credentials and login, then open konsole and execute sudo sddm, then I go out again to lock screen. I login again and I see the logs of sddm. Then do ctrl+c and end the sddm that i launched. Then I am able to use the desktop normally. (If i lock my screen again, issue re-appears)

My configurations:

I tried using both wayland and x11, I am facing the same issue.
The laptop has two graphics:

  1. Intel CometLake-U GT2 [UHD Graphics] which uses Mesa 23.2.1-1ubuntu3.1~22.04.2 drivers.
  2. AMD Lexa [Radeon 540X/550X/630 / RX 640 / E9171 MCM] which uses Mesa 23.2.1-1ubuntu3.1~22.04.2 drivers.

Kindly help me resolve this. I am running KDE Neon on my work laptop. I can’t keep facing the lock screen issue at work.


Issue 2 resolved: I got the login, logout from menu and ctrl+alt+del menu working by following this bug fix.

Also had an issue with Krunner, which was fixed by following this

However, Issue 1 still exists.

I’ve been thinking about this and maybe I should ask it in a different way:

  • The system boots.
  • Recovery mode works and can get to the desktop.
  • Normal boot crashes just before it gets to the desktop.
  1. What is the difference between those two modes?
  2. What is loading in normal mode that isn’t loading in recovery mode?
  3. How can I disable what’s loading in normal mode, item by item, to find what’s causing the problem?

See Black screen with cursor after updating KDE Neon to Plasma 6 - #4 by jsalatas.

Does that help?

Thank you, for replying.

I’m using KDE Plasma 5.27.5

I have a news update.
It’s been so many years since I’d used the command line as my main operating system interface that I forgot there are other TTY (virtual terminal windows) that you can use by holding the ctrl and alt keys and tap one of the F keys. F1 through F7 each give you a different terminal screen (TTY). If I hold down ctrl and alt then tap F7, I see the desktop.

Would using;

sudo apt autoremove
sudo pkcon refresh
sudo pkcon install libdecor-0-0
sudo pkcon install libsdl2-2.0-0
sudo pkcon install plasma-desktop
sudo pkcon install plasma-desktop-data
sudo reboot

redirect to the TTY with the desktop and fix that?

I have the same issues with my system. Using nvidia drivers on arch linux. System is completely unresponsive when resuming from sleep. I have to manually reboot to get the system back. Even when I restart the system the login screen doesn’t even show up. However if I type in the password on the black screen it does login and then it shows be the login splash and then the desktop. This is with wayland and plasma/kde.

Hi! I’m also facing this exact same issue as @manti2k explained in no. 1. I tried using the fix @ngraham suggested but with no avail. Any ideas on how to fix this? This only happens with X11 and not on Wayland.
Here’s my system information:

The same here. I’m also facing this same issue as @manti2k explained in no. 1. Is there a solution yet? This only happens with X11 and not on Wayland.
I do not like to change to Wayland as it does not properly support wacom tablets in Plasma 6. It would be available in 6.1…

Here’s my system information:

I’ve another issue 2’: I can open discover-plasma maximum once (somethimes not at all) per session. Once closed it does not give any reaction. Not by GUI nor by terminal…

Issue 1 (blank screen with only cursor after locking an X11 session) sounds like Bug 481308.

That’s described as, “Mouse cursor remains visible on it. It takes a long while for it to display the password prompt.” I don’t get either of those things happening.

Seems like the new Plasma 6.0.2 update fixed the problem

1 Like

update: since Plasma 6.0.2 login is working ok for me as well

discover-plasma still not starting

This threat has gone pretty far off the original topic and none of the replies solved the issue in the original post.

A user who’s far wiser than I, in the MX Linux forums, told me to try disabling “splash” in the boot options. That solved the issue and my system now boots normally.

1 Like