Using Wine or a Virtual Machine

I have two Windows-programs without Linux equivalent: ReMarkable (the tablet), but it’s no necessity, because I have the Android app and that works (via NextCloud I can transfer what I need) and Pacemaker Editor (Tonium, wonderful device :-), but stupid that you need a program to transfer mp3-files).
Now, I already paid for CrossOver to use it on my Mac (the mac client was to old to run). So I installed it with that and it works.

ReMarkable I tried to install with a Wine-app (I forgot which), but it didn’t work. I didn’t try too much.
Now I’m wondering, in general: does it work better to install and run Windows-applications in an emulator like VirtualBox? And which is good voor KDE, if there’s a difference?

if you haven’t tried bottles to run .exe windows software, then i would give that a try before abandoning the wine route.

haven’t dabbled much in VM stuff yet but i do know that it’s basically the same as a bare metal install of windows, so you have to have the windows .iso or disk media and a product key to make use of it.

but this comes without the benefit of windows actually running on bare metal… so things like access to your GPU and sound card and such can be more complicated than it would be under a full install directly on the machine.

here’s a article i have bookmarked for when i get serious about doing a VM.

there is also WinApps which makes use of the remote desktop protocol to give you a more seemless and snappy UX when using windows apps on your linux desktop

but my trial got stuck when i could not activate the RDP on the home edition of win10 and would need to upgrade to pro for $200.


Thanks, I will look into those options!

Complement: I used CrossOver, which is as I understand it a layer between Wine to make things easier. CrossOver uses bottles.

I don’t own a ReMarkable, but I have heard, that there are inoffical Linux apps surrounding that device. You might want to have a look here: GitHub - reHackable/awesome-reMarkable: A curated list of projects related to the reMarkable tablet , here: Install remarkable-desktop on Linux | Snap Store and consult the search engine of your choice. This might not directly address your request, but hopefully make your life a little easier.

Using VirtualBox for running a virtual machine is generally a good idea, but it requires using the VirtualBox third-party hypervisor, and installing its drivers and stuff (a lot of it is automated, but it could also break).

Another option is to use the virtual machine hypervisor that is built-in into Linux - you only need to install the UI for it, which is available on all Linux operating systems. One such UI is GNOME’s Boxes, but I think its too dumbed-down and I prefer Virtual Machine Manager. Get it from Discover (search for it on Discover, or just open the main menu and type “Virtual Machine Manager” the scroll down and choose "Get Virtual Machine Manager).

After you run Virtual Machine Manager, click “File” and “Add connection”, and in the dialog that opens choose “QEMU/KVM user session”, and “Connect”:

Then you should be able to click “New VM”, choose “Local install media”, “Next”, “Browse”, “Browse Local”, then select your Windows ISO image (you can download one for free from Microsoft’s website) and follow the easy to use wizard to set everything up.

1 Like

i agree using VMM to access KVM built into the kernel is likely the best way to go even if virtual box might make things a bit easier… regardless the the hardest part by far is going to be wading thru all the condescending windows steps (i mean it literally talks down to you without any prompting)

setting things up using the VMM GUI is pretty easy tho, even for a noob like me.

the free windows .iso files are all the home version tho so using the more advanced WinApps level of integration with with your linux desktop is out of the question unless you want to upgrade to a pro version of windows, as far as i can tell.

i’m sure somewere in the VMM settings there is a way to make a shared storage that is visible from both host and the VM so that files can be passed back and forth, but that did not fall out my first attempt at it.

edit: also of note, after installing VMM i had to reboot before it would “connect” to anything, after that it went as per the WinApps tutorial, which was easy to follow.

The “Multi-edition” ISO image you can get from here also has the professional licensing stuff - but you will need to have a Windows Professional license key to use it. Maybe you can do the “activate later” thing and run with the annoying “Windows requires activation” watermark, but I do not recommend or condone that. If you want to run Windows in a box - get a Windows license.

The libvirtd.service may not have started properly - in my tests on Neon it worked fine out of the box, if you use the `“QEMU/KVM user session”.

virtiofs is supposed to do that, but its not trivial to get it to work, and you can’t use it in “user session” mode.

that source is what i down loaded but without a product code i guess it defaults to the home edition, or perhaps i missed a step in the install process.

either way, i agree a product licensee is essential… supposedly i can up grade my win7 pro license for less than $200 but i haven’t tried that path yet.

the storage thing as well as cut n paste works via the RDP if i have the pro license (at least according the internet), but file i/o should still be able to go between host and VM even with out RDP, otherwise what’s the point of a VM on your linux desktop?

In order to get virtiofs working in a Windows guest, you need to installed the KVM guest addons for Windows as well as FUSE for Windows. Here’s an article that walks through the process.

I don’t think using this procedure requires a Windows Professional license, but I never tried to run the free Windows version.


Thank you markum. The first one states some scary warnings :slight_smile: also, I would have to reïnstall everything on ReMarkable. I might do so later, but for now I’ll look for less intrusive solutions.

The second link I already tried, that’s using Wine as well. The first time it opened once, not a second time (there’s a fix for that, but I didn’t manage to fix it). I tried it again now, but I’m stuck in the connecting phase. I’ll try again later :slight_smile:

I tried Virtual Box because that worked very well on my Mac, but it didn’t on Fedora now. I added missing parts and added security keys, as was mentioned in forums, but it didn’t work out.
Now I tried QEMU and the Virtual Machine Manager, and that did work! I’ve installed Windows with an iso image. The same problem as with Wine persist: everything is very small in the windows environment. But I guess I’ll find the solution for that. And I also have to make Windows account :'-).

Thanks skyfishfgoo. I succeeded with VMM as well! Didn’t try shared folders yet and also didn’t test if USB is recognised in Windows (that is a problem in CrossOver, I followed their steps to solve that, but I don’t get a correct usb-port/device name).

1 Like

That libvirt-thing is something Virtual Box complained about with me as well. Until now, I didn’t encounter that message with VVM.

I agree – running Windows in an Oracle VirtualBox VM is a reliable method of executing Windows applications on a Linux machine but –

  • It depends on the distribution and whoever it is that compiles builds the VirtualBox package for that distribution.

Here on openSUSE, everything is fine – we have a reliable responsible person.
And, I use a VirtualBox Windows VM to execute Japanese camera vendor’s application for processing RAW camera images – it used to be OK in Wine but, since more than a few years, that’s no longer the case.
My personal alternative would be to purchase an Apple box and retain my digiKam photography database on Linux – but, that’s in the future …

1 Like

Just run VMM, Virtual Machine Manager.

If you are going to run something windows then chances are it is because it isn’t on Linux and you can 't find something similar.

Sketch-Up was mine.

Wine bottles thrown from 50 meters doesn’t work. The VMM on it own was a fail.

The method is to buy yourself a new graphics card and add that to the system. Then dedicate the old one to windows. (Cause windows never deserves the best.)

Then you do some magic by reserving the IO of the card to be used for windows so Linux doesn’t nick it.

A bang, run any windows program on Linux like it was born here.

I bought a keyboard/mouse/screen switcher. The software for keyboard and mouse switching was problematic and the monitor I use, you need to stick your finger around the back to flip between graphics inputs. $30 of hardware resolved that.

I hit the wall with every other option. Sketch-Up needs to talk to a graphics card in ways Linux wouldn’t allow as far as I could see.

Took me 2 weeks of trying stuff, rejecting things that didn’t work like Wine, then messing about with the mouse keyboard issues and getting a hardware solution to that.

And since I set it up, I’ve managed to avoid all windows programs and not use it.

I wouldn’t call it easy or perfect but it is the only way that gives you Windows on Linux that is going to work for any program.

This might be helpful GPU passthrough with libvirt qemu kvm - Gentoo wiki

1 Like

Yeah, it feels pretty good to still have access in case all else fails…

You don’t need to use your distribution packages for that. VirtualBox provide their own repositories which you can use

Since the app has an Android version, Waydroid is also an option. Integration to Linux desktop is OK if you enable its multi-window mode.

What do you mean? That they also have a deb/rpm/etc file for each distro they are on?
If you are talking about the “all distributions” .run file. yeah, no, do not run that unless you know exactly what you are doing.

look at the link that I provided. You’ll see what distros are supported there. They provide either deb or rpm packages according to the distro.