What Neon channel to track for Plasma 6.0 RC?

I’ve been tracking Plasma 6.0 testing by installing Neon Unstable Edition ISO and updating from http://archive.neon.kde.org/unstable, but it seems unstable has started tracking Plasma 6.1 development - or at least that’s what the label at the bottom right corner of my desktop tells me.

I know of the following additional channels I can get from the Neon build system: release and testing.

release is - quite obviously - still on 5.27, while testing is - to the best of my understanding - a mess: a lot of stuff is still on 5 and a lot of other stuff missing - I tried enabling it last week and got a mostly broken system.

I know that the KDE recommended way of tracking Plasma 6.0 is to use kdesrc to build everything locally, but I had quite a lot of problems with that so I’m not going that route. Is there a way to consume a Neon build channel and stay on Plasma 6.0?

I’ve managed to downgrade to the testing repo and my desktop now says “KDE Plasma 6.0 RC1” - for the packages that are available. A lot of stuff is still only available on unstable so I didn’t downgrade them and they are left orphaned on my system - hopefully they will land in testing soon. In the process I bricked my Plasma session several times.

There is still weird stuff - some packages have older version than the same packages on the release repo, some packages do not have all of their requirements on the same testing repo (for example libkpimgapicore5), some packages do not even exist on testing (for example libappstreamqt2 that is required by the version of drkonqi-pk-debug-installer that is on testing).

So to summarize: testing is the current home of Plasma 6.0 RC1 but it is unusable by itself. It is possible to install Plasma 6.0 RC1 from Neon by selectively installing some packages from unstable and some from testing, but the result - if successful - is a very brittle system.

They were in the middle of diverting things to testing last I checked. I would probably wait until they spin a new ISO image.

I decided to kick out drkonqi-pk-debug-installer myself - I can install any debug things myself if necessary.

All I needed to do get everything else was to use dpkg with --force-overwrite a few times

Thanks for this, I’d been struggling to find out which channel would be RC1, and when. I’ll try to be patient and wait for an updated iso. :slight_smile: (Also running 6.1dev right now.)

Still no updated iso in testing, and apt update still fails for me. Any other options to get to working 6.0 RC1 ?

@freedriven - were you running unstable before, like me? If so you need to do a lot of downgrading. I wrote a script that did 95% of the work of writing an apt install command for downgrading from unstable to testing. If you’re interested I can post it.

I just had to do a fair amount of dpkg-foo to force all the new packages to overwrites files that were/are found in different Plasma 5 related packages.

The error mentions a new package found in /var/some-long-path-/to-a-file.deb that wants to overwrite a file provided by some-package.

I just needed to copy that package with its full path and use sudo dpkg -i --force-overwrite.

An example:
The error:

Unpacking kf6-kwallet (5.245.0+p22.04+vstable+git20240114.0957-0) ...
dpkg:0 error processing archive /var/cache/apt/archives/kf6-kwallet_5.245.0+p22.04+vstable+git20240114.0957-0_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/kwallet-query', which is also in package libkf5wallet-bin 5.113.0+p22.04+vstable+git20231224.0151-0

sudo dpkg -i --force-overwrite /var/cache/apt/archives/kf6-kwallet_5.245.0+p22.04+vstable+git20240114.0957-0_amd64.deb

And keep updating, and doing this for each new package that has this error.
(I am sure that there may be an easier method, but for the handful of times it was necessary, it wasn’t overly repetitive, to me.

Only do this for things listed as being in /var/cache/apt/archives/

Also, you do this at your own risk, of course :smiley:

No there is no easier method for those packaging mistakes the forcing of the overwrite is the only option to solve it. They have apparently not thought of anyone actually wanting to upgrade these installs with packages already installed. It seems it is a release distribution only for cases like that with fresh install the only option if you want it to succeed without the problems you and I have encountered with it. I gave up and went with a Kubuntu 24.04 development version to get the newer QT5 packages I wanted.

There is an easier way: when I started on the Plasma 6 train, I read somewhere (I think on Nate’s blog, but I can’t find it now) that Plasma 6 unstable neon packages may conflict with files from Plasma 6 packages with different names and to not worry about that, and just configure your system to allow dpkg to overwrite files automatically.

The instructions are simple: create a file /etc/dpkg/dpkg.cfg.d/plasma6 and put in it one line:


That’s it. Now dpkg will automatically have --force-overwrite set whenever it installs stuff. Once Plasma 6 is officially released, you should be able to remove that flag.

Thanks for the tip. I only needed to do this ~6 times, and I did take a moment to verify each one.

Being that Testing had just migrated from pre-release Plasma 5 code to Plasma 6 RC git pulls, it wasn’t entirely unexpected, and shouldn’t be an issue going forward.

In any case, an updated testing ISO image for testing is forthcoming.

Thanks for the quick help. Turns out, new testing iso available this morning! I’ll install and report back.

Ug, appears the latest iso isn’t bootable. Won’t boot in either virtualbox or from a live USB. Oh well, the wait continues.

I just now used the new Testing iso to do a clean install. No issues booting it whatsoever.

You might try re-downloading or verifying the image, etc.

Thanks, I forgot my wifi dropped multiple times during the first download. Yep, she boots now. THANKS.

1 Like

Have done a clean install of neon testing on a spare SSD and boots up fine but the cube effect is not working on neon RC1. Have tested RC1 on KaOS and no problem and also no problem on Fedora kinoite so not sure what the issue is. Checked and qt6-quick3d is installed.

Do you have 3 or more Virutal Desktops?

Yes I always have 4 virtual desktops on my PC. It doesn’t even work in live mode either. I have ISO on my Ventoy USB and when I boot into Neon Testing it looks fine but after setting up 4 virtual desktops and trying cube it does nothing. Like I said I have had this working on kaOS and Fedora but on Neon not doing anything.

Sorry I had only now time to test this. Seems like you are correct. I cannot use the cube effect on either testing or unstable in a VM.

Are you testing on real hardware or on a VM?

on a VM you have to make sure that 3d is enabled or it won’t show up. I am not trying on a VM but a spare SSD I have on my PC so bare metal and neon RC1 does not work either from live USB or once installed. As I said I have used this on kaOS and Fedora kinoite both running RC1 but neon doesn’t work. I would rather not use Arch or Fedora so would be nice if neon was working.

I think I also cannot make the cube effect work - if it should work by just going to “Desktop Effects”, enabling “cube” and then pressing Meta+C, then that indeed does not do anything for me.