When i alt tab to firefox in KDE Plasma 6, it changes the focused tab

For some reason, when i alt tab to firefox in KDE it changes the focused tab. It its quite anoying.

I also have sometimes this bug, but not consistently and I found no way to reproduce it

Silly question, since it is inconsistent this should not be it, but have you made sure to disable “Ctrl+Tab cycles through tabs in recently used order” in firefox general settings?

I’m leaving again, never mind me, I was never here. xD

Actually I haven’t. Might try it later, I’m not at home. Thank you.

I have a video reproducing it, but it can’t post here
Today I was coding and it was getting really annoying hahaha

It says ctrl+tab. My dyslectic a** just did not see it in time before pressing “reply”.

I think it’s strange bcs this wouldn’t happen in gnome, but it’s happening now in my kde install

Ok, so apparently now I can post links. Here it is: https://youtu.be/gKwT4UWwl1w?si=KFRK_9leLwnyjQbw

I mean, you clicked on another tab, and then in the next alt+tab it went BACK to “the old tab”, just like the ctrl+tab setting says it should do: " Ctrl+Tab cycles through tabs in recently used order".

Could also just be a coincidence.

I don’t think so
It always changes to tabs in the middle, even if I wasn’t focusing them before

Well, nobody can tell, because that is always the one you had focused before.
Unless you have identifed it always going to the middle one every single time then further data and testing is needed. xD

But it all could also be a complete coincidence and we are chasing windmills.

I’m also being driven insane by this bug. It seems like the Alt-Tab switching mechanism is getting stuck - that is, that it’s still registering you’re holding down Alt-Tab, so it’s trying to iterate through each of the available windows to present. This is incredibly annoying when I click a window to put it into focus, and instead a different window enters focus.

I’m also seeing similar behavior with the Desktop feature, where sometimes it also gets stuck. I’ve found that spamming Alt-Tab can sometimes get out of the stuck state, but sometimes it doesn’t and I don’t have a clear idea of what I’m doing to get out of it, other than randomly clicking things and trying to Alt-Tab to a new window.

It may be specific to how a program is implemented. I can’t seem to get the ‘refusal of focus’ to happen in VSCode, but I’m also experiencing it in Firefox and IntelliJ Ultimate.

Aha! This may be a smoking gun. I don’t have the bug happening in Firefox currently, but when I right clicked my IntelliJ window, it tried to show me the standard desktop options.

This dialog came up instead of the standard IntelliJ editor’s right click options, which makes me think that somehow the window is no longer ‘registered’?

EDIT: Just had the bug happen in Firefox, and it’s also trying to display Desktop options instead.
image

Edit 2: @Duha I’m unable to reply because of the 3-reply limit for new users. I’m running X11 and it seems to happen commonly here (once or more every hour or two). I’m not using the thumbnail grid task switcher version from the KDE Store if that’s what you mean, but I am using the one present in the OS. Alt-Tab is the only way I’ll switch windows.

Good morning sir
Other then changing the tabs that im focusing, it is also displaying this icon in my tabs as if I was moving tabs to different places. I’m not sure if it’s really related to the bug, but it is also happening consistently.
image

Are you using the thumbnail grid task switcher? Have you tried a different one?Does this happen on Wayland or X11? Do you switch tasks with ALT+TAB or are you using a different shortcut?

Can confirm this happening only on Wayland on both Plasma 5.27 and 6.0. This has never happened to me on X11.

It seems to occur randomly when Firefox loses focus in any way. Not only does this happen using Alt+Tab, I was also able to reproduce this by clicking anywhere on a Plasma panel, switching virtual desktops, or even clicking another window.

It appears that this behavior was filed as bug #1882963 in Mozilla’s Bugzilla site, but is sadly marked as a duplicate. However, the linked bug report (#1875031) actually addresses the random tab position indicator as shown in @gabrielwitor’s post above, which I got to reproduce randomly as well. Luckily #1875031 just got marked as resolved, so the annoying random position indicator should be gone by FF 126.

I really hope that the former bug report gets fixed soon, as this is the biggest annoyance I have with daily driving the Wayland session.

Update: Mozilla bug #1882963 just got reopened and someone was able to reproduce it so it’s now marked as confirmed! We’ll have to wait and see how quickly a fix for that gets pushed out.

(Due to the age of the post above I can’t edit it, so I had to create a new one)